Cia a tutti,
ho in ufficio 2 telecamere ip che registro da remoto e quindi mi occupano la maggior parte della banda in upload. Ovviamente ho anche un sistema di telefonia ip che passa attraverso un router cisco e ho bisogno che quando parte una chiamata la banda alle telecamere venga ridotta al minimo.
Avrei buttato giù questa configurazione ma c'e' qualcosa che ancora non va. Qualche idea?
access-list 105 remark VoIP Traffic(sip/iax2)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
class-map match-all voice-traffic
description [QOS VOICE]
match access-group 105
exit
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
exit
policy-map voice-policy
class voice-traffic
priority percent 70
exit
class telecamere
bandwidth 50
exit
class class-default
fair-queue
exit
exit
policy-map shaper
class class-default
shape average 300000
service-policy voice-policy
exit
exit
int Vlan1
service-policy output shaper
Grazie
QOS in upload
Moderatore: Federico.Lagni
- andrewp
- Messianic Network master
- Messaggi: 2199
- Iscritto il: lun 13 giu , 2005 7:32 pm
- Località: Roma
Mi sembra un ibrido di due soluzioni o_O
Prova lasciando:
In questo modo il VoIP è libero di mangiare il 70% della banda (occhio che è calcolata sul fisico...), alle telecamere invece sono sempre dedicati 50kbps.
Prova lasciando:
ed aggiungi:access-list 105 remark VoIP Traffic(sip/iax2)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
class-map match-all voice-traffic
description [QOS VOICE]
match access-group 105
exit
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
exit
policy-map voice-policy
class voice-traffic
priority percent 70
exit
e poi le applichi entrambe in out.policy-map camera
class telecamere
bandwidth 50
exit
In questo modo il VoIP è libero di mangiare il 70% della banda (occhio che è calcolata sul fisico...), alle telecamere invece sono sempre dedicati 50kbps.
Manipolatore di bit.
-
- Cisco fan
- Messaggi: 67
- Iscritto il: mar 26 lug , 2005 8:52 pm
il problema è proprio questo ( ecco perche cercavo di implementare una gestione del traffico in shape) perchè vorrei che quando non ci sono le chiamate le telecamere possano usare quanda banda in upload gli servono mentre quando parte una chiamata vengano ridimensionate a 50kbpsAndrea.Pezzotti ha scritto: ... alle telecamere invece sono sempre dedicati 50kbps.
Grazie
-
- Cisco fan
- Messaggi: 67
- Iscritto il: mar 26 lug , 2005 8:52 pm
Ma quando non c'e' una chiamata le telecamere usano più del 10% della banda disponibile? e invece vanno al 10% quando parte una chiamata?
Con i tuoi suggerimenti avrei elaborato questo, secondo te può andare?
access-list 105 remark VoIP Traffic(sip/iax2)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
class-map match-all voice-traffic
description [QOS VOICE]
match access-group 105
exit
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
exit
policy-map voice-policy
class voice-traffic
priority percent 90
exit
policy-map camera
class telecamere
priority percent 10
exit
int vlan1
service-policy output voice-policy
service-policy output camera
Grazie
Con i tuoi suggerimenti avrei elaborato questo, secondo te può andare?
access-list 105 remark VoIP Traffic(sip/iax2)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
class-map match-all voice-traffic
description [QOS VOICE]
match access-group 105
exit
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
exit
policy-map voice-policy
class voice-traffic
priority percent 90
exit
policy-map camera
class telecamere
priority percent 10
exit
int vlan1
service-policy output voice-policy
service-policy output camera
Grazie
- Wizard
- Intergalactic subspace network admin
- Messaggi: 3441
- Iscritto il: ven 03 feb , 2006 10:04 am
- Località: Emilia Romagna
- Contatta:
Inatnro io cambiarei
class-map match-all voice-traffic
in
class-map match-any voice-traffic
Poi, la policy-map deve essere una sola e al interno fai le 2 (o +) class-map
class-map match-all voice-traffic
in
class-map match-any voice-traffic
Poi, la policy-map deve essere una sola e al interno fai le 2 (o +) class-map
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
-
- Cisco fan
- Messaggi: 67
- Iscritto il: mar 26 lug , 2005 8:52 pm
access-list 105 remark VoIP Traffic(sip/iax2)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
class-map match-any voice-traffic
description [QOS VOICE]
match access-group 105
exit
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
exit
policy-map voice-policy
class voice-traffic
priority percent 70
exit
class telecamere
priority percent 10
exit
exit
int vlan1
service-policy output voice-policy
ma in questo modo le telecamere utilizzano tutta la banda disponibile senza nessuna chiamata e scendono al 10% quando parte una chiamata?
Grazie
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
class-map match-any voice-traffic
description [QOS VOICE]
match access-group 105
exit
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
exit
policy-map voice-policy
class voice-traffic
priority percent 70
exit
class telecamere
priority percent 10
exit
exit
int vlan1
service-policy output voice-policy
ma in questo modo le telecamere utilizzano tutta la banda disponibile senza nessuna chiamata e scendono al 10% quando parte una chiamata?
Grazie
-
- Cisco fan
- Messaggi: 67
- Iscritto il: mar 26 lug , 2005 8:52 pm
ho bisogno di una consulenza anche a pagamento riguardo questo problema, gentilmente chi fosse interessato può contattarmi a [email protected]
Grazie
Grazie
- Wizard
- Intergalactic subspace network admin
- Messaggi: 3441
- Iscritto il: ven 03 feb , 2006 10:04 am
- Località: Emilia Romagna
- Contatta:
Facci vedere la config completa...
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
-
- Cisco fan
- Messaggi: 67
- Iscritto il: mar 26 lug , 2005 8:52 pm
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ROUTER
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool CLIENT
import all
network 10.5.36.0 255.255.255.0
default-router 10.5.36.254
lease 0 2
!
!
no ip domain lookup
ip inspect name myfw cuseeme timeout 3600
ip inspect name myfw ftp timeout 3600
ip inspect name myfw rcmd timeout 3600
ip inspect name myfw realaudio timeout 3600
ip inspect name myfw smtp timeout 3600
ip inspect name myfw tftp timeout 30
ip inspect name myfw udp timeout 3600
ip inspect name myfw tcp timeout 3600
ip inspect name myfw h323 timeout 3600
ip inspect name myfw sip timeout 3600
username router password 7 xxxxxxxxxxxxxxxxxx
!
!
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
class-map match-any voice-traffic
description [QOS VOICE]
match access-group 105
!
!
policy-map voice-policy
class voice-traffic
priority percent 70
class telecamere
priority percent 5
!
!
interface ATM0
no ip address
no ip mroute-cache
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
service-policy output voice-policy
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.5.36.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1200
hold-queue 100 out
!
interface Dialer0
bandwidth 1280
ip address negotiated
ip access-group 111 in
ip nat outside
ip inspect myfw out
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request
hold-queue 224 in
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip nat inside source static tcp 10.5.36.10 1800 interface Dialer0 1800
ip nat inside source static tcp 10.5.36.11 1801 interface Dialer0 1801
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Dialer0 overload
!
!
access-list 101 permit ip 10.5.36.0 0.0.0.255 any
access-list 105 remark VoIP Traffic(sip/iax2)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
access-list 111 permit tcp any any eq 1800
access-list 111 permit tcp any any eq 1801
access-list 111 permit tcp any any eq telnet
access-list 111 permit udp any any eq non500-isakmp
access-list 111 permit icmp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit esp any any
access-list 111 permit udp any any eq 5060
access-list 111 permit udp any any eq 5061
access-list 111 permit udp any any eq 4569
access-list 111 permit udp any any eq 5004
access-list 111 permit udp any any range 10000 20000
access-list 111 permit tcp any any eq 1720
dialer-list 1 protocol ip permit
no cdp run
!
!
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ROUTER
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool CLIENT
import all
network 10.5.36.0 255.255.255.0
default-router 10.5.36.254
lease 0 2
!
!
no ip domain lookup
ip inspect name myfw cuseeme timeout 3600
ip inspect name myfw ftp timeout 3600
ip inspect name myfw rcmd timeout 3600
ip inspect name myfw realaudio timeout 3600
ip inspect name myfw smtp timeout 3600
ip inspect name myfw tftp timeout 30
ip inspect name myfw udp timeout 3600
ip inspect name myfw tcp timeout 3600
ip inspect name myfw h323 timeout 3600
ip inspect name myfw sip timeout 3600
username router password 7 xxxxxxxxxxxxxxxxxx
!
!
class-map match-any telecamere
description [TELECAMERE]
match access-group 110
class-map match-any voice-traffic
description [QOS VOICE]
match access-group 105
!
!
policy-map voice-policy
class voice-traffic
priority percent 70
class telecamere
priority percent 5
!
!
interface ATM0
no ip address
no ip mroute-cache
atm vc-per-vp 64
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
service-policy output voice-policy
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.5.36.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1200
hold-queue 100 out
!
interface Dialer0
bandwidth 1280
ip address negotiated
ip access-group 111 in
ip nat outside
ip inspect myfw out
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request
hold-queue 224 in
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip nat inside source static tcp 10.5.36.10 1800 interface Dialer0 1800
ip nat inside source static tcp 10.5.36.11 1801 interface Dialer0 1801
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Dialer0 overload
!
!
access-list 101 permit ip 10.5.36.0 0.0.0.255 any
access-list 105 remark VoIP Traffic(sip/iax2)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any eq 5061
access-list 105 permit udp any any eq 4569
access-list 105 permit udp any any eq 5004
access-list 105 permit udp any any range 10000 20000
access-list 105 permit tcp any any eq 1720
access-list 110 permit tcp any any eq 1800
access-list 110 permit tcp any any eq 1801
access-list 111 permit tcp any any eq 1800
access-list 111 permit tcp any any eq 1801
access-list 111 permit tcp any any eq telnet
access-list 111 permit udp any any eq non500-isakmp
access-list 111 permit icmp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit esp any any
access-list 111 permit udp any any eq 5060
access-list 111 permit udp any any eq 5061
access-list 111 permit udp any any eq 4569
access-list 111 permit udp any any eq 5004
access-list 111 permit udp any any range 10000 20000
access-list 111 permit tcp any any eq 1720
dialer-list 1 protocol ip permit
no cdp run
!
!