Config pronta per 857W: ADSL2 - DHCP - FW - DynDNS - WiFi

Configurazioni per connettività ADSL, ISDN e switch per privati e piccole network

Moderators: Federico.Lagni, TheIrish, Wizard, andrewp

Config pronta per 857W: ADSL2 - DHCP - FW - DynDNS - WiFi

Postby @lan72 » Thu 12 Jun , 2008 9:07 am

Salve a tutti, tenevo a farvi sapere che sono molto riconoscente nei confronti di questo forum perchè ho trovato persone capaci e allo stesso molto disponibili, considerando che i cisco per chi partiva da 0 come me sono praticamente impossibili, qui ho avuto la possibilità in poco tempo di imparare quanto basta per poterne configurare uno.

ps. un ringraziamento particolare va a Wizard..


Volevo contribuire allegando la mia configurazione per Cisco 857W funzionante al 100% con:

Alice 20 Mega (casa ip dinamico)
Dhcp Server
DynDns
Wifi con Wpa2
Filtro MAC WiFi
Firewall
Ntp Update

il range del hdcp è dal 192.168.0.1 al 192.168.0.220
l'indirizzo del router è 192.168.0.221

per semplificare il tutto, ho predisposto dei campi caratterizzati da parentesi quadra dove allinterno deve essere inserito il valore desiderato


:arrow:

Code: Select all
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname [NOME-ROUTER]
!
boot-start-marker
boot-end-marker
!
logging buffered 52000
enable secret 5 [SECRET-PASSWORD]
!
no aaa new-model
clock timezone MET 1
clock summer-time MEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
!
dot11 association mac-list 700
dot11 syslog
dot11 vlan-name WiFi vlan 1
!
dot11 ssid [NOME-SSID]
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 [PASSWORD-WIFI-MASSIMO-63-CARATTERI]
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.221 192.168.0.254
!
ip dhcp pool Pool1
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.221
   dns-server [1-DNS-X-CLIENT] [2-DNS-x-CLIENT]
   lease infinite
!
!
ip cef
ip inspect log drop-pkt
ip inspect name Firewall cuseeme
ip inspect name Firewall dns
ip inspect name Firewall ftp
ip inspect name Firewall h323
ip inspect name Firewall https
ip inspect name Firewall icmp
ip inspect name Firewall imap
ip inspect name Firewall pop3
ip inspect name Firewall rcmd
ip inspect name Firewall realaudio
ip inspect name Firewall rtsp
ip inspect name Firewall esmtp
ip inspect name Firewall sqlnet
ip inspect name Firewall streamworks
ip inspect name Firewall tftp
ip inspect name Firewall tcp
ip inspect name Firewall udp
ip inspect name Firewall vdolive
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain name cisco.com
ip name-server [1-DNS-RISOLUXIONE-NOMI-X-ROUTER]
ip name-server [2-DNS-RISOLUXIONE-NOMI-X-ROUTER]
ip ddns update method dyndns1
 HTTP
  add http://[NOMEUTENTE]:[PASSWORD]@members.dyndns.org/nic/update?system=dyndns&ho
stname=<h>&myip=<a>
  remove http://[NOMEUTENTE]:[PASSWORD]@members.dyndns.org/nic/update?system=dyndns
&hostname=<h>&myip=<a>
!
!
username [NOME-UTENTE-ACCESSO-ROUTER] privilege 15 secret 5 [PASSWORD]
!
!
archive
 log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode adsl2+
!
interface ATM0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers aes-ccm tkip
 !
 ssid [NOME-SSID-WIFI]
 !
 speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 b
asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 station-role root
 world-mode dot11d country IT both
 l2-filter bridge-group-acl
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip tcp adjust-mss 1452
 bridge-group 1
!
interface Dialer0
 ip ddns update hostname [HOST-DYNDNS].gotdns.com
 ip ddns update dyndns1
 ip address negotiated
 ip access-group 101 in
 ip mtu 1492
 ip inspect Firewall out
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username [UTENTE]@alice.it password 7 [PASSWORD]
!
interface BVI1
 ip address 192.168.0.221 255.255.255.0
 ip access-group 102 in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 101 remark Traffico abilitato ad entrare nel router da internet
access-list 101 deny   ip 0.0.0.0 0.255.255.255 any
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip 169.254.0.0 0.0.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 192.0.2.0 0.0.0.255 any
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 198.18.0.0 0.1.255.255 any
access-list 101 deny   ip 224.0.0.0 0.15.255.255 any
access-list 101 deny   ip any host 255.255.255.255
access-list 101 permit udp host [1-DNS-RISOLUXIONE-NOMI-X-ROUTER] eq domain any
access-list 101 permit udp host [2-DNS-RISOLUXIONE-NOMI-X-ROUTER] eq domain any
access-list 101 permit tcp host 63.208.196.96 eq www any log
access-list 101 permit udp host 207.46.232.42 eq ntp any
access-list 101 permit udp host 192.43.244.18 eq ntp any
access-list 101 permit gre any any
access-list 101 deny   icmp any any echo
access-list 101 deny   ip any any log
access-list 102 remark Traffico abilitato ad entrare nel router dalla ethernet
access-list 102 permit ip any host 192.168.0.221
access-list 102 deny   ip any host 192.168.0.255
access-list 102 deny   udp any any eq tftp log
access-list 102 deny   ip any 0.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 10.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 127.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 169.254.0.0 0.0.255.255 log
access-list 102 deny   ip any 172.16.0.0 0.15.255.255 log
access-list 102 deny   ip any 192.0.2.0 0.0.0.255 log
access-list 102 deny   ip any 192.168.0.0 0.0.255.255 log
access-list 102 deny   ip any 198.18.0.0 0.1.255.255 log
access-list 102 deny   udp any any eq 135 log
access-list 102 deny   tcp any any eq 135 log
access-list 102 deny   udp any any eq netbios-ns log
access-list 102 deny   udp any any eq netbios-dgm log
access-list 102 deny   tcp any any eq 445 log
access-list 102 permit ip 192.168.0.0 0.0.0.255 any
access-list 102 permit ip any host 255.255.255.255
access-list 102 deny   ip any any log
access-list 700 permit [MAC-ADDRESS-WIFI-ABILITATI] (Esempio 0015.1181.a949   0000.0000.0000)
access-list 700 deny   0000.0000.0000   ffff.ffff.ffff
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
sntp server 207.46.197.32
sntp server 192.43.244.18
end




Spero di aver fatto cosa gradita...


Saluti :wink:
Agostino
Last edited by @lan72 on Tue 17 Jun , 2008 1:12 pm, edited 1 time in total.
share your knowledge

.::.::. Cisco867VAE [IOS:15.4.3.M6a|FW:35j23je]
User avatar
@lan72
Cisco enlightened user
 
Posts: 157
Joined: Thu 22 May , 2008 4:36 pm
Location: Sicily

Postby Wizard » Thu 12 Jun , 2008 9:24 am

Sarà di sicuro cosa gradita!

@ admin: riesci a renderlo "importante"?!
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
User avatar
Wizard
Intergalactic subspace network admin
 
Posts: 3441
Joined: Fri 03 Feb , 2006 10:04 am
Location: Emilia Romagna

Postby @lan72 » Tue 17 Jun , 2008 1:17 pm

ho effettuao una piccola modofica, ho tolto i logging IP:


Code: Select all
logging 192.168.0.1
logging 192.168.0.2
logging 192.168.0.3


non credo che possono servire per una configurazione tipo standard.


Saluti :wink:
Agostino
share your knowledge

.::.::. Cisco867VAE [IOS:15.4.3.M6a|FW:35j23je]
User avatar
@lan72
Cisco enlightened user
 
Posts: 157
Joined: Thu 22 May , 2008 4:36 pm
Location: Sicily

Postby Wizard » Tue 17 Jun , 2008 2:34 pm

Ho modificato io il titolo del topic e l'ho reso Importante
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
User avatar
Wizard
Intergalactic subspace network admin
 
Posts: 3441
Joined: Fri 03 Feb , 2006 10:04 am
Location: Emilia Romagna

Postby giocomail » Wed 25 Jun , 2008 8:39 am

Andrebbe bene per un 877?
User avatar
giocomail
Cisco fan
 
Posts: 28
Joined: Wed 28 May , 2008 9:28 am

Postby Wizard » Wed 25 Jun , 2008 9:02 am

Si va bene anche per gli 877
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
User avatar
Wizard
Intergalactic subspace network admin
 
Posts: 3441
Joined: Fri 03 Feb , 2006 10:04 am
Location: Emilia Romagna

Postby MoL0ToV » Wed 25 Jun , 2008 4:19 pm

ho preso la configurazione iniziale e l'ho customizzata per l'utilizzo con libero ADSL Absolute anzichè alice.

Ho eliminato i vari filtri e firewall dato che non ne ho bisogno e ho aggiunto l'ip forwarding per p2p.

Ecco a voi la config:

http://www.bbwire.net/modules.php?name= ... &p=856#856
MoL0ToV
n00b
 
Posts: 9
Joined: Fri 02 May , 2008 5:40 pm

Postby JosephFalck » Thu 11 Dec , 2008 8:51 pm

Scusate la domanda ma va bene con un cisco 877 W ed una linea 7 mega?

Joseph Falck.
JosephFalck
n00b
 
Posts: 12
Joined: Wed 12 Nov , 2008 10:18 pm

Postby Wizard » Fri 12 Dec , 2008 9:55 am

Certo!
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
User avatar
Wizard
Intergalactic subspace network admin
 
Posts: 3441
Joined: Fri 03 Feb , 2006 10:04 am
Location: Emilia Romagna

Postby Helix » Fri 12 Dec , 2008 10:00 am

magari metti il dsl operating in modalità auto per essere più precisi
---
Ciao, Leonardo

"Guarda che il VSS è migliore dell' MPLS"
"Io amo le rotte statiche e non mi fido dei protocolli di RUTING"
"Io ho lavorato per Telecom...li è tutto Layer 2 e tutto RUTING statico"
"L'MPLS VPN è come l' ATM e farà la sua stessa fine"
"A noi l'MPLS non CE n'teressa...mejo se usamo il FlexLink"
"Spostiamo il Livello 3 della Vlan dal Core al Service Edge ma senza modificare il RUTING..."
"Ma sul 3650 a 4 porte si può fare lo stAcK?"
"Noi usiamo quel coso lì...che maschera gli IPPPI'...capito no?"
"Forse non hai capito...puoi risolvere il problema usando le sub-vlan"

Cisco CCNP, CCDP Certified
User avatar
Helix
Messianic Network master
 
Posts: 1175
Joined: Tue 04 Dec , 2007 6:45 pm
Location: Frosinone

Postby JosephFalck » Fri 12 Dec , 2008 1:53 pm

Ho caricato il template con le parti modificate però il router non va neanche i train. Come posso risolvere?

Joseph Falck.
JosephFalck
n00b
 
Posts: 12
Joined: Wed 12 Nov , 2008 10:18 pm

Postby Helix » Fri 12 Dec , 2008 1:55 pm

JosephFalck wrote:Ho caricato il template con le parti modificate però il router non va neanche i train. Come posso risolvere?

Joseph Falck.


Puoi spiegarti meglio?
---
Ciao, Leonardo

"Guarda che il VSS è migliore dell' MPLS"
"Io amo le rotte statiche e non mi fido dei protocolli di RUTING"
"Io ho lavorato per Telecom...li è tutto Layer 2 e tutto RUTING statico"
"L'MPLS VPN è come l' ATM e farà la sua stessa fine"
"A noi l'MPLS non CE n'teressa...mejo se usamo il FlexLink"
"Spostiamo il Livello 3 della Vlan dal Core al Service Edge ma senza modificare il RUTING..."
"Ma sul 3650 a 4 porte si può fare lo stAcK?"
"Noi usiamo quel coso lì...che maschera gli IPPPI'...capito no?"
"Forse non hai capito...puoi risolvere il problema usando le sub-vlan"

Cisco CCNP, CCDP Certified
User avatar
Helix
Messianic Network master
 
Posts: 1175
Joined: Tue 04 Dec , 2007 6:45 pm
Location: Frosinone

Postby JosephFalck » Fri 12 Dec , 2008 4:23 pm

Ho copiato ed incollato tramite HyperTerminal il template (inseriti con i miei dati) ed il router non riesce a prendere la linea (la spia CD non rimane fissa e non lampeggia per nulla).
JosephFalck
n00b
 
Posts: 12
Joined: Wed 12 Nov , 2008 10:18 pm

Postby Helix » Fri 12 Dec , 2008 4:46 pm

ma la configurazione te la prende?

fai un pò di comandi per il troubleshooting...

show run
show ip int brief
show int atm0
sh dsl int
sh log
---
Ciao, Leonardo

"Guarda che il VSS è migliore dell' MPLS"
"Io amo le rotte statiche e non mi fido dei protocolli di RUTING"
"Io ho lavorato per Telecom...li è tutto Layer 2 e tutto RUTING statico"
"L'MPLS VPN è come l' ATM e farà la sua stessa fine"
"A noi l'MPLS non CE n'teressa...mejo se usamo il FlexLink"
"Spostiamo il Livello 3 della Vlan dal Core al Service Edge ma senza modificare il RUTING..."
"Ma sul 3650 a 4 porte si può fare lo stAcK?"
"Noi usiamo quel coso lì...che maschera gli IPPPI'...capito no?"
"Forse non hai capito...puoi risolvere il problema usando le sub-vlan"

Cisco CCNP, CCDP Certified
User avatar
Helix
Messianic Network master
 
Posts: 1175
Joined: Tue 04 Dec , 2007 6:45 pm
Location: Frosinone

Postby JosephFalck » Fri 12 Dec , 2008 6:44 pm

La configurazione la prende. Solo che non mi da segni di vita. Con i vari comandi vedo tutte le interface in up. Che può essere?
JosephFalck
n00b
 
Posts: 12
Joined: Wed 12 Nov , 2008 10:18 pm

Next

Return to Configurazioni End User

Who is online

Users browsing this forum: No registered users and 1 guest