pppoe far disconnettere dialer1

Configurazioni per connettività ADSL, ISDN e switch per privati e piccole network

Moderators: Federico.Lagni, TheIrish, Wizard, andrewp

pppoe far disconnettere dialer1

Postby consultazione » Tue 28 Apr , 2020 6:06 pm

ho 2 interfacce ethernet
una lan e un'altra che va verso un router in bridge

creo il dialer 1 che si collega in pppoe e mi da un indirizzo ip pubblico
e funziona tutto bene

ora non riesco a capire una cosa: se stacco il cavo ethernet che va verso il router in bridge si dovrebbe disconnettere il dialer 1, e quando ricollego il cavo ethernet si dovrebbe ricollegare il dialer 1
invece succede che se stacco e riattacco il cavo non succede proprio niente, e dopo averlo ricollegato, il dialer e' ancora funzionante con l'ip precedente

c'e' qualche opzione da impostare per fare in modo che staccando un cavo il dialer venga forzato a ricollegarsi?

grazie
consultazione
Cisco pathologically enlightened user
 
Posts: 203
Joined: Mon 31 Oct , 2005 6:10 pm

Re: pppoe far disconnettere dialer1

Postby paolomat75 » Wed 29 Apr , 2020 1:17 pm

Ciao.
Quanto lo lasci staccato il cavo?

Paolo
CCNA R&S and CCNP Route Pass - Studing....
Non cade foglia che l'inconscio non voglia (S.B.)
paolomat75
Messianic Network master
 
Posts: 2935
Joined: Fri 29 Jan , 2010 10:25 am
Location: Prov di GE

Re: pppoe far disconnettere dialer1

Postby consultazione » Wed 29 Apr , 2020 1:35 pm

anche un minuto

a me servirebbe una cosa istantanea
tipo stacco, dopo due/tre secondi riattacco e via

la stessa cosa la faccio con un firewall e funziona perfettamente
consultazione
Cisco pathologically enlightened user
 
Posts: 203
Joined: Mon 31 Oct , 2005 6:10 pm

Re: pppoe far disconnettere dialer1

Postby paolomat75 » Wed 29 Apr , 2020 2:03 pm

Strano. A me va giù dopo un paio di secondi.
Che router e IOS usi?

Paolo
CCNA R&S and CCNP Route Pass - Studing....
Non cade foglia che l'inconscio non voglia (S.B.)
paolomat75
Messianic Network master
 
Posts: 2935
Joined: Fri 29 Jan , 2010 10:25 am
Location: Prov di GE

Re: pppoe far disconnettere dialer1

Postby consultazione » Wed 29 Apr , 2020 2:20 pm

roba vecchia
ho a disposizione 837, 877, 28xx, 18xx
ios 12.xx 15.xx
dopo posto una configurazione
forse e' qualche opzione.. boh
consultazione
Cisco pathologically enlightened user
 
Posts: 203
Joined: Mon 31 Oct , 2005 6:10 pm

Re: pppoe far disconnettere dialer1

Postby consultazione » Wed 29 Apr , 2020 3:11 pm

per es. questo e' un 837


Code: Select all
837-90-90-1#sh run
Building configuration...

Current configuration : 4002 bytes
!
! No configuration change since last restart
!
version 12.4
no service pad
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname 837-90-90-1
!
boot-start-marker
boot-end-marker
!
enable secret 5 ...................
!
no aaa new-model
clock timezone Rome 1
clock summer-time Rome recurring last Sun Mar 2:00 last Sun Oct 3:00
!
!
!         
!
ip cef
no ip domain lookup
ip domain name yourdomain.com
ip name-server 151.99.0.100
ip name-server 151.99.125.1
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
interface Ethernet0
 description porte 1 2 3 - interfaccia verso il router in bridge
 ip address 172.20.0.3 255.255.255.0
 no ip proxy-arp
 pppoe enable group global
 pppoe-client dial-pool-number 1
 hold-queue 100 out
!
interface Ethernet2
 description porta 4 - interfaccia lan interna
 ip address 10.90.90.1 255.255.255.0
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 hold-queue 100 out
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
interface Dialer1
 description Connessione PPPOE
 mtu 1492
 ip address negotiated
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 no ip route-cache cef
 ip tcp adjust-mss 1452
 dialer pool 1
 no cdp enable
 ppp chap hostname aliceadsl
 ppp chap password 7 0207085208030E255F42
 ppp pap sent-username aliceadsl password 7 01120A0D580E070B3240
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 10.90.90.0 0.0.0.255
no cdp run
!         
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 access-class 1 in
 exec-timeout 240 0
 password 7 xxxxxxxxxxxxxxx
 login
 transport input telnet
!
scheduler max-task-time 5000
end
consultazione
Cisco pathologically enlightened user
 
Posts: 203
Joined: Mon 31 Oct , 2005 6:10 pm

Re: pppoe far disconnettere dialer1

Postby consultazione » Wed 29 Apr , 2020 3:15 pm

stacco il cavo verso il router in bridge
Code: Select all
Apr 29 14:12:57: %LINK-3-UPDOWN: Interface FastEthernet1, changed state to down
Apr 29 14:12:57: %LINK-3-UPDOWN: Interface Ethernet0, changed state to down
Apr 29 14:12:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1, changed state to down
Apr 29 14:12:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to down


riattacco il cavo
Code: Select all
Apr 29 14:13:37: %LINK-3-UPDOWN: Interface FastEthernet1, changed state to up
Apr 29 14:13:37: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Apr 29 14:13:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1, changed state to up
Apr 29 14:13:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up


ma il dialer1 e' rimasto uguale
io vorrei che venisse fatta un'altra sessione pppoe quando riattacco il cavo con cambio di ip
come se facessi shutdown e no shutdown del dialer


pare che il dialer1 venga a cadere dopo qualche minuto da quando rileva che il cavo di rete e' stato staccato

come fare per velocizzare? tipo un paio di secondi?
consultazione
Cisco pathologically enlightened user
 
Posts: 203
Joined: Mon 31 Oct , 2005 6:10 pm


Return to Configurazioni End User

Who is online

Users browsing this forum: No registered users and 2 guests

cron