Cisco 887 vdsl subnet pubblica ma voglio fare nat

Configurazioni per connettività ADSL, ISDN e switch per privati e piccole network

Moderators: Federico.Lagni, TheIrish, Wizard, andrewp

Cisco 887 vdsl subnet pubblica ma voglio fare nat

Postby davide0522 » Tue 15 May , 2018 8:38 pm

Buonasera.
Il provider mi fa connettere con la dialer ppp e su essa ottengo un ip dinamico a.b.c.d (che non naviga)
Contestualmente mi routa 8 ip pubblici, es 80.80.80.0/29
Se metto il primo disponibile sulla vlan1, cioè 80.80.80.1, poi ci attacco un firewall a cui do la 80.80.80.2, nessun problema.
Il problema me lo pongo nel momento in cui non voglio lavorare in lan con ip pubblici ma con privati.
Ovvero vorrei dare sulla vlan ip 192.168.1.1 /24 e fare il classico overload su uno degli ip pubblici statici che mi da il provider.
Mi è stato suggerito di lavorare con una loopback. Ho tentato e qualcosa ho ottenuto, ma con la conf. che allego ad esempio non lo pingo da fuori nè lo raggiungo in telnet sul pubblico (80.80.80.1).
Da dentro navigo e sw vado su un sito show ip mi mostra il 80.80.80.1
Qualcuno può suggerirmi qualche "miglioria" a questa conf ? E, anzi, prima di tutto, dirmi se è decente e va bene ?
Grazie anticipatamente

Code: Select all
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VDSL_TRENOVE
!
boot-start-marker
boot-end-marker
!
!
enable secret 0 xxxxxxx
!
no aaa new-model
crypto pki token default removal timeout 0
!
!
ip source-route
!
!
!
!
!
ip cef
ip name-server 8.8.8.8
no ipv6 cef
!
!
license udi pid CISCO887VA-K9 sn Fxxxx
!
!
vtp domain LGFL2
vtp mode transparent
username xxxxxx password 0 xxxxxxx
!
!
!
!
controller VDSL 0
 operating mode vdsl2
 firmware filename flash:VA_A_38k1_B_38h_24g1.bin
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 80.80.80.1 255.255.255.248
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
!
interface Ethernet0
 no ip address
 no fair-queue
!
interface Ethernet0.835
 encapsulation dot1Q 201
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip mtu 1492
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer1
 description PPPoE per FTTC VDSL2
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp chap hostname xxxxxxx
 ppp chap password 0 xxxxxxx
 no ppp chap wait
 ppp pap sent-username xxxxxxx password 0 xxxxxxx
 no ppp pap wait
 no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
no ip nat service sip udp port 5060
ip nat inside source list 101 interface Loopback1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
logging esm config
access-list 101 permit ip any any
!
!
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login local
 transport input all
!
end
User avatar
davide0522
Cisco fan
 
Posts: 40
Joined: Wed 31 Mar , 2010 4:22 pm

Return to Configurazioni End User

Who is online

Users browsing this forum: No registered users and 0 guests