Multicasting

Tutto ciò che ha a che fare con la configurazione di apparati Cisco (e non rientra nelle altre categorie)

Moderators: Federico.Lagni, TheIrish, Wizard, tonycimo, andrewp

Multicasting

Postby peiro » Sat 14 Nov , 2009 6:15 am

Ho capito la teoria ma non ho capito molto bene l'impiego.
Per esempio, non ho capito cosa serve la conversione da ipv4 a mac-address. Mi spiego il calcolo l'ho capito ma non capisco perchè serve. Ho fatto una mia mezza teoria, tipo lo implemento nella porta dello switch dove attacco non so se il ricevente o la sorgente; seconda domanda l'indirizzo multicasting che assegno ai gruppi lo posso inventare liberamente oppure devo attenermi a qualche calcolo.
peiro
n00b
 
Posts: 7
Joined: Sat 14 Nov , 2009 6:11 am

Re: Multicasting

Postby Gianremo.Smisek » Sat 14 Nov , 2009 11:23 am

peiro wrote:Ho capito la teoria ma non ho capito molto bene l'impiego.


Ti serve in ambiti dove la normale rete IP non arriva oppure affoga. E' il caso dell'IPTV, Videoconferenza, e-learning etc. Se hai una sola sorgente e piu' destinatari, la sorgente IP Unicast crea piu' flussi per ogni destinatario (e quindi anche negli hop intermedi). Con il Multicast, invece, il flusso e' univoco per tutti i destinatari risparmiando banda. (ovviamente anche unicast e multicast hanno i propri pro/contro).

peiro wrote:Per esempio, non ho capito cosa serve la conversione da ipv4 a mac-address. Mi spiego il calcolo l'ho capito ma non capisco perchè serve. Ho fatto una mia mezza teoria, tipo lo implemento nella porta dello switch dove attacco non so se il ricevente o la sorgente;


No! Il multicast-mac address non sei tu ad implementarlo ma, appunto gli apparati. Come ben sai, un pacchetto viene forwardato tramite gli indirizzi IP (source e destination). Questi indirizzi, pero', servono appunto solo per la sorgente e la destinazione. Per gli hop intermedi, il pacchetto viene incapsulato in un frame e quindi troviamo come indirizzo sorgente e di destinazione i mac-address rispettivi del sender e del receiver. Ora, appurato questo, la stessa cosa ce l'abbiamo nel Multicast con la differenza che noi non abbiamo un singolo host ma un gruppo di host. Ed e' qui' che entra in gioco il mapping dell'ipv4 (del gruppo) ed il mac-address (0x01-00-5e-XX-XX-XX). Per cui se avessimo un pacchetto (e quindi un frame) da mandare ad un gruppo multicast (per es. 224.10.0.1), quest'IP sara' presente nel campo campo header "destination IP" del pacchetto (nel source avremo l'IP dell'host che invia), mentre, nel campo source del frame, avremo il mac-addr dell'host di cui sopra e come destination mac-addr 0x01-00-5e-XX-XX-XX, che nel nostro esempio mappera' su 01-00-5e-0a-00-01 (quindi tutti gli IP multicast che mappano in quel mac-address, con il calcolo che gia' conosci).

peiro wrote:seconda domanda l'indirizzo multicasting che assegno ai gruppi lo posso inventare liberamente oppure devo attenermi a qualche calcolo.


Non puoi inventarli... devono cadere nel range 239.192.0.0 - 239.251.255.255 (local scope organization).

Spero di esser stato chiaro,

ciao!
Last edited by Gianremo.Smisek on Sat 14 Nov , 2009 11:32 am, edited 3 times in total.
Gianremo.Smisek
Messianic Network master
 
Posts: 1159
Joined: Sun 11 Mar , 2007 2:23 pm
Location: Termoli

Re: Multicasting

Postby pierky » Sat 14 Nov , 2009 11:24 am

Ciao,

peiro wrote:non ho capito cosa serve la conversione da ipv4 a mac-address.


le schede di rete normalmente filtrano a livello datalink i frames che vedono sul cavo in base al MAC di destinazione; praticamente passano al sistema operativo soltanto quei frames dove la destinazione è il loro MAC address (broadcast a parte).

Quando un host decide di entrare a far parte di un insieme di riceventi per un determinato gruppo multicast, informa la scheda di rete di tenere in considerazione i frames con destinazione il MAC address tradotto dall'IP di multicast. Così la sceda di rete sa di dover inviare ai livelli superiori anche quei frames là.

peiro wrote:l'indirizzo multicasting che assegno ai gruppi lo posso inventare liberamente oppure devo attenermi a qualche calcolo


Per la scelta dell'IP di gruppo non c'è da fare alcun calcolo, basta far attenzione a non scegliere qualcosa di riservato ad altri scopi (http://www.iana.org/assignments/multicast-addresses/). In generale, per IP privati 239.0.0.0/8 .

Ciao
pierky
Cisco fan
 
Posts: 50
Joined: Sat 19 Jul , 2008 11:28 am

Postby peiro » Sat 14 Nov , 2009 6:00 pm

Grazie mille per le repliche, ma ho ancora dei dubbi e vi prpongo un lab.

R1# show run
!
hostname R1
!
ip multicast-routing
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip pim dense-mode
no shutdown
!
end
R2# show run
!
hostname R2
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
ip igmp join-group 229.7.7.7
no shutdown
!
end
R3# show run
!
hostname R3
!
interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
ip igmp join-group 229.7.7.7
no shutdown
!
end
SW1# show run
!
hostname SW1
!
ip igmp snooping vlan 1 static 0100.5e07.0707 interface Fa0/9
!
interface FastEthernet0/1
switchport mode access
!
interface FastEthernet0/3
switchport mode access
!
interface FastEthernet0/5
switchport mode access
!
interface Vlan1
ip address 192.168.1.10 255.255.255.0
no shutdown
!
end


prima
SW1# show mac address-table multicast
Vlan Mac Address Type Ports
---- ----------- ---- -----
1 0100.5e00.0128 IGMP Fa0/1
1 0100.5e07.0707 IGMP Fa0/1, Fa0/3, Fa0/5

SW1(config)# ip igmp snooping vlan 1 static 0100.5e07.0707 interface
fastethernet 0/9

dopo
SW1# show mac address-table multicast
Vlan Mac Address Type Ports
---- ----------- ---- -----
1 0100.5e00.0128 IGMP Fa0/1
1 0100.5e07.0707 USER Fa0/1, Fa0/3, Fa0/5,
Fa0/9

Inserendo igmp snooping abilito anche l'interfaccia f0/9 a partecipare al multicasting? Questo comando devo implementarlo per ogni host che voglio far partecipare al multicasting? Oppure mi serve solo se devo applicare un traffico multicasting di risposta, tipo una video conferenza o una whiteboard? O se abilito tipo un traffico di sola trassmissione tipo video, non ho bisogno di abilitarlo? Io pensavo che se abilito un'interfaccia del router nel gruppo tutta la catena partecipava in automatico al traffico.
peiro
n00b
 
Posts: 7
Joined: Sat 14 Nov , 2009 6:11 am

Postby pierky » Sat 14 Nov , 2009 6:45 pm

Quando un host si aggancia ad un gruppo multicast invia un IGMP join al suo router di riferimento.

L'IGMP snooping consente agli switch che sono nel mezzo (tra host e router) di sapere che su una determinata porta ci sta un host che intende essere receiver di un gruppo multicast.

Il comando che hai dato tu serve per forzare sullo switch la partecipazione della porta Fa0/9 nel gruppo di multicast identificato dal MAC address fornito. Generalmente non dev'essere implementato in maniera statica, lo snooping serve proprio per informare dinamicamente lo switch circa i partecipanti al multicast. Il traffico di risposta sarà di tipo unicast, quindi è al di fuori da questi ragionamenti.
pierky
Cisco fan
 
Posts: 50
Joined: Sat 19 Jul , 2008 11:28 am

e un'altra domanda penso sempre attinente

Postby peiro » Sat 14 Nov , 2009 6:46 pm

Quando abilito delle interfacce al multicasting devo stare attento a quali posiziono. Per intenderci il RPF checking per quanto ho capito, in parole povere, utilizza le interfacce abilitate all'ascolto ha ricevere il trafffico e utilizza le altre interfacce all'uscita del traffico. Quindi la join nel gruppo devo abilitarla solo nelle interfacce che arriva il flusso? Le altre interfacce in automatico diventano le interfacce di output? Ma se utilizzo un many-to-many model? Per quanto sò un many-to-many model abilita gli host a essere source and receiver ciò vuol dire che se utilizzo un servizio del genere il RPF come si comporta? cavolo mi dispiace che non riesco ad inserire delle immagini per intenderci meglio.
esempio
inter s0/0
ip igmp join-group 225.25.25.25
ip pim sparse-dense-mode
description interfaccia d'ascolto
inter f0/0
ip pim sparse-dense-mode
description interfaccia d'uscita x questa interfaccia ometto la join, cosi indico che è una interfaccia di output, oppure devo inserirla nel gruppo?
Last edited by peiro on Sat 14 Nov , 2009 8:03 pm, edited 1 time in total.
peiro
n00b
 
Posts: 7
Joined: Sat 14 Nov , 2009 6:11 am

Postby peiro » Sat 14 Nov , 2009 7:03 pm

pierky wrote:Quando un host si aggancia ad un gruppo multicast invia un IGMP join al suo router di riferimento.

L'IGMP snooping consente agli switch che sono nel mezzo (tra host e router) di sapere che su una determinata porta ci sta un host che intende essere receiver di un gruppo multicast.

Il comando che hai dato tu serve per forzare sullo switch la partecipazione della porta Fa0/9 nel gruppo di multicast identificato dal MAC address fornito. Generalmente non dev'essere implementato in maniera statica, lo snooping serve proprio per informare dinamicamente lo switch circa i partecipanti al multicast. Il traffico di risposta sarà di tipo unicast, quindi è al di fuori da questi ragionamenti.

Ok scusa, quindi non voglio dire una cavolata, quindi diciamo che se la sorgente fa parte della Vlan1 tutto gli utenti di quella Vlan in automatico, solo chi fa la richiesta, avranno tramite lo snooping il mac-address del multicast assegnato? E io per abilitarne altri host che non fanno parte di quella vlan, posso forzarlo a manella? Scusa la miriade di domande ma la manualistica Cisco secondo me è buona per la teoria per passare l'esame ma per utilizzare i concetti spiega un pò malino.
peiro
n00b
 
Posts: 7
Joined: Sat 14 Nov , 2009 6:11 am

Re: Multicasting

Postby peiro » Sat 14 Nov , 2009 7:51 pm

intel wrote:
peiro wrote:Ho capito la teoria ma non ho capito molto bene l'impiego.


Ti serve in ambiti dove la normale rete IP non arriva oppure affoga. E' il caso dell'IPTV, Videoconferenza, e-learning etc. Se hai una sola sorgente e piu' destinatari, la sorgente IP Unicast crea piu' flussi per ogni destinatario (e quindi anche negli hop intermedi). Con il Multicast, invece, il flusso e' univoco per tutti i destinatari risparmiando banda. (ovviamente anche unicast e multicast hanno i propri pro/contro).

peiro wrote:Per esempio, non ho capito cosa serve la conversione da ipv4 a mac-address. Mi spiego il calcolo l'ho capito ma non capisco perchè serve. Ho fatto una mia mezza teoria, tipo lo implemento nella porta dello switch dove attacco non so se il ricevente o la sorgente;


No! Il multicast-mac address non sei tu ad implementarlo ma, appunto gli apparati. Come ben sai, un pacchetto viene forwardato tramite gli indirizzi IP (source e destination). Questi indirizzi, pero', servono appunto solo per la sorgente e la destinazione. Per gli hop intermedi, il pacchetto viene incapsulato in un frame e quindi troviamo come indirizzo sorgente e di destinazione i mac-address rispettivi del sender e del receiver. Ora, appurato questo, la stessa cosa ce l'abbiamo nel Multicast con la differenza che noi non abbiamo un singolo host ma un gruppo di host. Ed e' qui' che entra in gioco il mapping dell'ipv4 (del gruppo) ed il mac-address (0x01-00-5e-XX-XX-XX). Per cui se avessimo un pacchetto (e quindi un frame) da mandare ad un gruppo multicast (per es. 224.10.0.1), quest'IP sara' presente nel campo campo header "destination IP" del pacchetto (nel source avremo l'IP dell'host che invia), mentre, nel campo source del frame, avremo il mac-addr dell'host di cui sopra e come destination mac-addr 0x01-00-5e-XX-XX-XX, che nel nostro esempio mappera' su 01-00-5e-0a-00-01 (quindi tutti gli IP multicast che mappano in quel mac-address, con il calcolo che gia' conosci).

peiro wrote:seconda domanda l'indirizzo multicasting che assegno ai gruppi lo posso inventare liberamente oppure devo attenermi a qualche calcolo.


Non puoi inventarli... devono cadere nel range 239.192.0.0 - 239.251.255.255 (local scope organization).

Spero di esser stato chiaro,

ciao!

ok queste cose bene o male le sapevo, ma forse mi sono spiegato male. Non intendevo inventarli ma ad esempio se voglio sapere l'indirizzo multicast della sorgente, devo dare il comando, sul router dove c'è la sorgente, il comando show ip mroute, oppure l'indirizzo multicst è generato dal tipo di servizio, tipo per un servizio video utilizzo 239.1.1.1, o è generato dal tipo di software che utilizzo, ad esempio VLC ha un determinato indirizzo e ghost server un altro?
peiro
n00b
 
Posts: 7
Joined: Sat 14 Nov , 2009 6:11 am

Postby Gianremo.Smisek » Sat 14 Nov , 2009 8:10 pm

lo decidono i programmatori del software multicast, l'importante e' che sia nel range specificato da IANA
Gianremo.Smisek
Messianic Network master
 
Posts: 1159
Joined: Sun 11 Mar , 2007 2:23 pm
Location: Termoli

Re: Multicasting

Postby pierky » Sun 15 Nov , 2009 1:46 pm

Nel momento in cui un host fa richiesta di join ad un gruppo multicast, e questa richiesta attraversa lo switch, in automatico tramite lo snooping la porta di quell'host viene dichiarata come receiver di quel gruppo.

peiro wrote:Quindi la join nel gruppo devo abilitarla solo nelle interfacce che arriva il flusso?


Il join del gruppo lo fa l'host che desidera agganciarsi a quel gruppo, non devi farlo tu da switch.

peiro wrote:E io per abilitarne altri host che non fanno parte di quella vlan, posso forzarlo a manella?


Gli altri host che fanno parte di altre VLANs a loro volta invieranno dei join per il gruppo di loro interesse e, come prima, lo snooping mapperà multicast-MAC / porta sullo switch.
pierky
Cisco fan
 
Posts: 50
Joined: Sat 19 Jul , 2008 11:28 am

Re: Multicasting

Postby ghisirds » Sun 02 Feb , 2020 8:30 am

Ciao a tutti,
ecco una breve descrizione di cosa si parla nel topic.
casa.tiscali.it/magazine/articoli/a-cosa-servono-indirizzo-ip-e-mac-address/594a1ac6-6fe6-11e8-a4dd-005056a86fbe
Saluti a tutti.

__________________
Consulenza seo reggio emilia e posizionamento > Visita ora SitiWeb.RE
ghisirds
Cisco fan
 
Posts: 39
Joined: Fri 06 Jul , 2007 9:04 pm


Return to Configurazioni

Who is online

Users browsing this forum: No registered users and 1 guest

cron