Config pronta per 857W: ADSL2 - DHCP - FW - DynDNS - WiFi

Configurazioni per connettività ADSL, ISDN e switch per privati e piccole network

Moderators: Federico.Lagni, TheIrish, Wizard, andrewp

Postby Helix » Fri 12 Dec , 2008 6:51 pm

JosephFalck wrote:La configurazione la prende. Solo che non mi da segni di vita. Con i vari comandi vedo tutte le interface in up. Che può essere?



puoi postare i comandi che ti ho suggerito sia qui che in MP?
---
Ciao, Leonardo

"Guarda che il VSS è migliore dell' MPLS"
"Io amo le rotte statiche e non mi fido dei protocolli di RUTING"
"Io ho lavorato per Telecom...li è tutto Layer 2 e tutto RUTING statico"
"L'MPLS VPN è come l' ATM e farà la sua stessa fine"
"A noi l'MPLS non CE n'teressa...mejo se usamo il FlexLink"
"Spostiamo il Livello 3 della Vlan dal Core al Service Edge ma senza modificare il RUTING..."
"Ma sul 3650 a 4 porte si può fare lo stAcK?"
"Noi usiamo quel coso lì...che maschera gli IPPPI'...capito no?"
"Forse non hai capito...puoi risolvere il problema usando le sub-vlan"

Cisco CCNP, CCDP Certified
User avatar
Helix
Messianic Network master
 
Posts: 1175
Joined: Tue 04 Dec , 2007 6:45 pm
Location: Frosinone

Postby JosephFalck » Sat 13 Dec , 2008 10:30 pm

Ok. Appena sono a casa faccio tutto. Ora sono fuori sede. Grazie di tutto per ora.

Joseph Falck.
JosephFalck
n00b
 
Posts: 12
Joined: Wed 12 Nov , 2008 10:18 pm

Postby JosephFalck » Thu 18 Dec , 2008 8:41 pm

Con il comando sh ip int brief

Interface IP-Address OK? Method Status Prot
ocol
FastEthernet0 unassigned YES unset up down

FastEthernet1 unassigned YES unset up down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

Dot11Radio0 unassigned YES manual administratively down down

Dot11Radio0.1 unassigned YES unset administratively down down

ATM0 unassigned YES manual administratively down down

ATM0.1 unassigned YES unset administratively down down

Vlan1 unassigned YES manual up down

Dialer0 unassigned YES manual up up
NVI0 unassigned NO unset up up

BVI1 192.168.0.221 YES manual down down
JosephFalck
n00b
 
Posts: 12
Joined: Wed 12 Nov , 2008 10:18 pm

Postby Clockys » Thu 26 Mar , 2009 4:46 pm

ho seguito questa spiegazione per azzerare la config del mio cisco 877

Code: Select all
How to load a config file onto a Cisco router

Plug the blue serial cable [known as a console cable] that came with your Cisco router into the console port on the router and the serial port in your computer. Start up your favourite terminal program (such as HyperTerminal - select "Direct to COMx"). The correct terminal settings are 9600 baud, 8 data bits, no parity, 1 stop bit, and I usually choose hardware flow control. For reliability, you also need to set the line delay to 100ms (File/Properties/Settings/ASCII Setup).

If the router is on, switch it off. Now turn the router on. Note that it takes about two minutes for router to complete booting. If the router asks if you want to run the setup wizard, say no. If it asks you if you want to get started tap return a couple of times. If you get nothing within 30 seconds of turning the router on, tap return a few times. If you still get nothing then check your serial connections and parameters.

For safety, lets start by wiping the routers current config. Enter these commands:
enable
erase nvram:
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

Press "y" to erase the routers config. Then enter the below commands. Note that the router may not ask you to save the current config. If it does, make sure you say no - we are trying to wipe the config.
reload
System configuration has been modified. Save? [yes/no]: no
Proceed with reload? [confirm]

Press "y" to let the router reboot. For those people who have some familiarity with Cisco routers the "erase nvram:" command has supersede the "write erase" and "erase startup-config" commands (these commands all do the same thing).

When the router has completed booting this time it will ask if you want to run the setup wizard, say "no".
It should eventually tell you to press "return to get started".
Tap return a few times.

Now we need to go into config mode:
enable
config terminal

Now copy the config you want to load onto the router into the clipboard (hint: CTRL-A then CTRL-C), and paste into HyperTerminal (Edit/Paste To Host). Once it has pasted in, you need to save the config.
CTRL-Z
copy running-config startup-config


e poi ho caricato la config proposta in questo topic.
ho una alice 7mb plus con ip statico.

ho provato "ping www.google.it" ma niente

ho speranze ?

allego qualche comando che ho visto chiedere da Wizard


Code: Select all
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES unset  up                    down
FastEthernet1              unassigned      YES unset  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
ATM0                       unassigned      YES NVRAM  up                    up
ATM0.1                     unassigned      YES unset  up                    up
Vlan1                      unassigned      YES NVRAM  up                    down
NVI0                       unassigned      YES unset  administratively down down
Dialer0                    unassigned      YES NVRAM  up                    up
BVI1                       192.168.0.221   YES NVRAM  down                  down
Virtual-Access1            unassigned      YES unset  down                  down


Code: Select all
show int atm0
ATM0 is up, line protocol is up
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 640 Kbit/sec, DLY 570 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  10 maximum active VCs, 1024 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     160 packets input, 9344 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     160 packets output, 11888 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out


Code: Select all
sh dsl int
ATM0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x03                            0x2
Vendor ID:       'STMI'                          'P   '
Vendor Specific: 0x0000                          0x0000
Vendor Country:  0x0F                            0xB5
Chip ID:         C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   98%                             78%
Noise Margin:    11.5 dB                         18.0 dB
Output Power:    20.0 dBm                        12.5 dBm
Attenuation:     21.0 dB                         11.5 dB
Defect Status:   None                            None
Last Fail Code:  None
Watchdog Counter: 0x9A
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      8255 (0 spurious)
PHY Access Err:  0
Activations:     1
LED Status:      ON
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded
FW Version:      3.0.14

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          7008                0           640                 0
Cells:                  332                0        573948                 0
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                0             1                 0
Header Errors:            0                0             0                 0
Total BER:                0E-0           0E-0
Leakage Average BER:      0E-0           0E-0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 2 4 7 7 9 9 A A A A
010: A A A 9 9 9 9 9 8 8 7 6 5 4 2 0
020: 0 0 0 0 0 A B B B B B B C C B B
030: B B C B B B B B B B B B B B B B
040: 0 B B B A B B B A A B B B B B B
050: A 2 A A A A A A A A A A A A A A
060: A A A A A A A A A A A A A A A A
070: A A A A A 9 A 9 A A 9 9 9 9 9 A
080: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
090: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
0A0: 9 9 9 9 9 9 9 9 9 9 9 8 8 9 8 9
0B0: 9 9 9 8 9 9 9 9 9 9 9 9 9 8 8 9
0C0: 9 8 8 9 8 8 8 8 8 8 8 8 8 8 8 8
0D0: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8
0E0: 8 8 8 8 8 8 8 8 8 8 8 7 8 7 8 8
0F0: 7 8 7 8 7 7 8 7 7 7 8 8 8 8 8 8

DSL: Training log buffer capability is not enabled
Clockys
n00b
 
Posts: 20
Joined: Thu 26 Mar , 2009 11:12 am

Postby Fiffo » Tue 28 Jul , 2009 4:09 pm

Salve, io ho un router Cisco 877W e la suddetta connessione ma non sono ancora riuscito a configurarlo avendo conoscenze tecniche troppo scarse. Pertanto se qualcuno di voi mi può aiutare, ne sarei grato. Ad esempio: ho provato una volta a configurare il Cisco ma il mio tentativo era svolto in un interfaccia, se volessi usare questa configurazione di "solo testo" come dovrei fare?
Fiffo
n00b
 
Posts: 15
Joined: Tue 28 Jul , 2009 4:04 pm

Postby Wizard » Tue 04 Aug , 2009 11:27 am

io ho un router Cisco 877W e la suddetta connessione ma non sono ancora riuscito a configurarlo


Crea un topic dedicato con la tua attuale config, vedremo di correggerla insieme
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
User avatar
Wizard
Intergalactic subspace network admin
 
Posts: 3441
Joined: Fri 03 Feb , 2006 10:04 am
Location: Emilia Romagna

Postby Fiffo » Fri 14 Aug , 2009 10:05 pm

Se volessi utilizzare questa conf, ma con alice business 20mb e cisco 877w va ugualmente bene?
Nel caso è possibile collegare pc fisso con ethernet e il resto tramite WiFi? E in che modo?
Se volessi aprire delle porte tcp/udp?
Grazie in anticipo per le risposte!
Fiffo
n00b
 
Posts: 15
Joined: Tue 28 Jul , 2009 4:04 pm

Postby Fiffo » Sat 15 Aug , 2009 3:40 pm

Ok, i comandi per settare le porte dove li piazzo nella conf?
Fiffo
n00b
 
Posts: 15
Joined: Tue 28 Jul , 2009 4:04 pm

Postby Fiffo » Sat 15 Aug , 2009 5:45 pm

cavolata... comunque ho dei problemi con la conf... sono riuscito solo a piazzare nome router e password alcuni comandi come quelli per il ssid non me li prende...
Fiffo
n00b
 
Posts: 15
Joined: Tue 28 Jul , 2009 4:04 pm

Postby Fiffo » Sat 15 Aug , 2009 7:13 pm

eccolo integralmente:

Router#sh ver
Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(6)T9, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 09-Oct-07 18:56 by khuie

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

Router uptime is 1 minute
System returned to ROM by power-on
System image file is "flash:c870-advsecurityk9-mz.124-6.T9.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
--More--

Tra i problemi si va ad aggiungere il fatto che la mia asdl è ad ip statico, cosa bisognerebbe cambiare?
Fiffo
n00b
 
Posts: 15
Joined: Tue 28 Jul , 2009 4:04 pm

Re: Config pronta per 857W: ADSL2 - DHCP - FW - DynDNS - WiF

Postby cosibello » Wed 11 Jun , 2014 12:15 am

@lan72 wrote:Salve a tutti, tenevo a farvi sapere che sono molto riconoscente nei confronti di questo forum perchè ho trovato persone capaci e allo stesso molto disponibili, considerando che i cisco per chi partiva da 0 come me sono praticamente impossibili, qui ho avuto la possibilità in poco tempo di imparare quanto basta per poterne configurare uno.

ps. un ringraziamento particolare va a Wizard..


Volevo contribuire allegando la mia configurazione per Cisco 857W funzionante al 100% con:

Alice 20 Mega (casa ip dinamico)
Dhcp Server
DynDns
Wifi con Wpa2
Filtro MAC WiFi
Firewall
Ntp Update

il range del hdcp è dal 192.168.0.1 al 192.168.0.220
l'indirizzo del router è 192.168.0.221

per semplificare il tutto, ho predisposto dei campi caratterizzati da parentesi quadra dove allinterno deve essere inserito il valore desiderato


:arrow:

Code: Select all
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname [NOME-ROUTER]
!
boot-start-marker
boot-end-marker
!
logging buffered 52000
enable secret 5 [SECRET-PASSWORD]
!
no aaa new-model
clock timezone MET 1
clock summer-time MEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
!
dot11 association mac-list 700
dot11 syslog
dot11 vlan-name WiFi vlan 1
!
dot11 ssid [NOME-SSID]
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 [PASSWORD-WIFI-MASSIMO-63-CARATTERI]
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.221 192.168.0.254
!
ip dhcp pool Pool1
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.221
   dns-server [1-DNS-X-CLIENT] [2-DNS-x-CLIENT]
   lease infinite
!
!
ip cef
ip inspect log drop-pkt
ip inspect name Firewall cuseeme
ip inspect name Firewall dns
ip inspect name Firewall ftp
ip inspect name Firewall h323
ip inspect name Firewall https
ip inspect name Firewall icmp
ip inspect name Firewall imap
ip inspect name Firewall pop3
ip inspect name Firewall rcmd
ip inspect name Firewall realaudio
ip inspect name Firewall rtsp
ip inspect name Firewall esmtp
ip inspect name Firewall sqlnet
ip inspect name Firewall streamworks
ip inspect name Firewall tftp
ip inspect name Firewall tcp
ip inspect name Firewall udp
ip inspect name Firewall vdolive
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain name cisco.com
ip name-server [1-DNS-RISOLUXIONE-NOMI-X-ROUTER]
ip name-server [2-DNS-RISOLUXIONE-NOMI-X-ROUTER]
ip ddns update method dyndns1
 HTTP
  add http://[NOMEUTENTE]:[PASSWORD]@members.dyndns.org/nic/update?system=dyndns&ho
stname=<h>&myip=<a>
  remove http://[NOMEUTENTE]:[PASSWORD]@members.dyndns.org/nic/update?system=dyndns
&hostname=<h>&myip=<a>
!
!
username [NOME-UTENTE-ACCESSO-ROUTER] privilege 15 secret 5 [PASSWORD]
!
!
archive
 log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode adsl2+
!
interface ATM0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers aes-ccm tkip
 !
 ssid [NOME-SSID-WIFI]
 !
 speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 b
asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 station-role root
 world-mode dot11d country IT both
 l2-filter bridge-group-acl
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip tcp adjust-mss 1452
 bridge-group 1
!
interface Dialer0
 ip ddns update hostname [HOST-DYNDNS].gotdns.com
 ip ddns update dyndns1
 ip address negotiated
 ip access-group 101 in
 ip mtu 1492
 ip inspect Firewall out
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username [UTENTE]@alice.it password 7 [PASSWORD]
!
interface BVI1
 ip address 192.168.0.221 255.255.255.0
 ip access-group 102 in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 101 remark Traffico abilitato ad entrare nel router da internet
access-list 101 deny   ip 0.0.0.0 0.255.255.255 any
access-list 101 deny   ip 10.0.0.0 0.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 deny   ip 169.254.0.0 0.0.255.255 any
access-list 101 deny   ip 172.16.0.0 0.15.255.255 any
access-list 101 deny   ip 192.0.2.0 0.0.0.255 any
access-list 101 deny   ip 192.168.0.0 0.0.255.255 any
access-list 101 deny   ip 198.18.0.0 0.1.255.255 any
access-list 101 deny   ip 224.0.0.0 0.15.255.255 any
access-list 101 deny   ip any host 255.255.255.255
access-list 101 permit udp host [1-DNS-RISOLUXIONE-NOMI-X-ROUTER] eq domain any
access-list 101 permit udp host [2-DNS-RISOLUXIONE-NOMI-X-ROUTER] eq domain any
access-list 101 permit tcp host 63.208.196.96 eq www any log
access-list 101 permit udp host 207.46.232.42 eq ntp any
access-list 101 permit udp host 192.43.244.18 eq ntp any
access-list 101 permit gre any any
access-list 101 deny   icmp any any echo
access-list 101 deny   ip any any log
access-list 102 remark Traffico abilitato ad entrare nel router dalla ethernet
access-list 102 permit ip any host 192.168.0.221
access-list 102 deny   ip any host 192.168.0.255
access-list 102 deny   udp any any eq tftp log
access-list 102 deny   ip any 0.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 10.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 127.0.0.0 0.255.255.255 log
access-list 102 deny   ip any 169.254.0.0 0.0.255.255 log
access-list 102 deny   ip any 172.16.0.0 0.15.255.255 log
access-list 102 deny   ip any 192.0.2.0 0.0.0.255 log
access-list 102 deny   ip any 192.168.0.0 0.0.255.255 log
access-list 102 deny   ip any 198.18.0.0 0.1.255.255 log
access-list 102 deny   udp any any eq 135 log
access-list 102 deny   tcp any any eq 135 log
access-list 102 deny   udp any any eq netbios-ns log
access-list 102 deny   udp any any eq netbios-dgm log
access-list 102 deny   tcp any any eq 445 log
access-list 102 permit ip 192.168.0.0 0.0.0.255 any
access-list 102 permit ip any host 255.255.255.255
access-list 102 deny   ip any any log
access-list 700 permit [MAC-ADDRESS-WIFI-ABILITATI] (Esempio 0015.1181.a949   0000.0000.0000)
access-list 700 deny   0000.0000.0000   ffff.ffff.ffff
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
sntp server 207.46.197.32
sntp server 192.43.244.18
end




Spero di aver fatto cosa gradita...


Saluti :wink:
Agostino


=========================================================

Salve, sono un neofita nel campo ho scritto papale papale dopo aver digitato config t, router(config)#, ma la config sul mio Cisco887MW non ne vuole sapere, alcuni comandi non li prende, esempio router(config)#interface ethernet 0 mi da errore, anche il comando dot11, la versione ios e 15.0 "Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.0(1)M7, RELEASE SOFTWARE (fc2)

Nome firmware Ios = c880data-universalk9-mz.150-1.M7.bin

Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Fri 05-Aug-11 02:01 by prod_rel_team

ROM: System Bootstrap, Version 12.4(22r)YB5, RELEASE SOFTWARE (fc1)

yourname uptime is 8 minutes
System returned to ROM by power-on
System restarted at 15:43:09 UTC Fri Apr 18 2014
System image file is "flash:c880data-universalk9-mz.150-1.M7.bin"
Last reload type: Normal Reload

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.
Cisco 887M (MPC8300) processor (revision 1.0) with 708608K/77824K bytes of memory.
Processor board ID FGL1543204S

4 FastEthernet interfaces
1 Gigabit Ethernet interface
1 ISDN Basic Rate interface
1 ATM interface
1 terminal line
1 Virtual Private Network (VPN) Module
1 cisco Embedded AP (s)
256K bytes of non-volatile configuration memory.
126000K bytes of ATA CompactFlash (Read/Write)

License Info:
License UDI:
-------------------------------------------------
Device# PID SN
-------------------------------------------------
*0 CISCO887MW-GN-E-K9 FGE1543204A
----------------------------------------------------------------------------------
Se vi può essere utile allego una precedente config fatta da un amico, che venuto a casa lo ha configurato, devo dire funzionava alla grande anche se non aveva configurato il Wireless, su una porta ethernet ho messo un router con Wireless incorporato...funzionava. Il giorno dopo ha fatto una erase config, lo hanno chiamato al telefono ed è partito per Londra. Adesso sono rimasto senza Config
Se qualche anima pia può aiutarmi anche a pagamento ne sarei felice, sto cercando di riscriverla ma evidentemente erro in quache comando, se qualcuno con un po di pazienza una errata corrige.... Grazie anticipatamente

QUESTA E' LA CONFIG TROVATA IN GIRO SU QUESTO FORUM:
Router(config)#hostname Cisco887
Cisco887(config)#enable password admin
Cisco887(config)#password admin
Router(config)#exit
!
ACCESSO TRAMITE CONSOL
Cisco887M(config)#line console 0
Cisco887M(config-line)#password admin
Cisco887M(config-line)#login Cisco887
Cisco887(config)#enable secret admin2 Dove admin2 è la password di Amministratore. Importante che la password non vada persa.
!
Cisco887(config)#username admin privilege 15 password 0 admin <impostiamo username e la passwd per accedere al router da terminale o da http>
!
Router(config)#clock timezone MET 1
Router(config)#clock summer-time MEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
service-module wlan-ap 0 bootimage autonomous
crypto pki token default removal timeout 0
!
Router(config)crypto pki trustpoint TP-self-signed-470017061
Router(config) enrollment selfsigned
Router(config) subject-name cn=IOS-Self-Signed-Certificate-470017061
Router(config) revocation-check none
Router(config) rsakeypair TP-self-signed-470017061
!
Router(config)Router(config)crypto pki certificate chain TP-self-signed-470017061
Router(config)certificate self-signed 01
Cisco887#
!
CONFIGURAZIONE INTERFACCIA
Cisco887(config)# (Configurare l’interfaccia ethernet)
Cisco887(config)#interface ethernet 0
Cisco887(config-if)#ip address 192.168.111.1 255.255.255.0 (Rendete operativa l’interfaccia 192... con sotto maschera 255 ecc.)
Cisco887(config-if)#no shutdown
Cisco887(config-if)#exit (per ritornare al prompt)
Cisco887(config)#
Cisco887(config)#ip nat translation max-entries 5000
Cisco887(config)#ip nat translation timeout 420
Cisco887(config)#ip nat translation tcp-timeout 120
Cisco887(config)#ip nat translation pptp-timeout 420
Cisco887(config)#ip nat translation finrst-timeout 300
Cisco887(config)#ip nat translation syn-timeout 120
Cisco887(config)#ip nat translation udp-timeout 120
Cisco887(config)#ip nat translation dns-timeout 300
Cisco887(config)#ip nat translation icmp-timeout 120
Cisco887(config)#service dhcp
Cisco887(config)#no ip dhcp conflict logging
Cisco887(config)#ip dhcp pool DHCP_RETE_INTERNA
Cisco887(dhcp-config)#network 192.168.111.0 255.255.255.0
Cisco887(dhcp-config)#default-router 192.168.111.1
Cisco887(dhcp-config)#dns-server 8.8.8.8 8.8.4.4
Cisco887(dhcp-config)#lease infinite
Cisco887(dhcp-config)#exit
Cisco887(config)#ip dhcp excluded-address 192.168.111.10 192.168.111.25 Esempio Cisco887(config)#service dhcp
Cisco887(config)#END
!
CONFIGURAZIONE DEL DIALER necessario eseguire la configurazione per Internet (Dialer + ATM).
Cisco887(config)#interface dialer 0
Cisco887(config-if)#ip address negotiated
Cisco887(config-if)#ip nat outside
Cisco887(config-if)#encapsulation ppp
Cisco887(config-if)#dialer pool 1
Cisco887(config-if)#exit
Cisco887#
!
CONFIGURAZIONE INTERFACCIA ATM
Cisco887(config)#no ip unreachables
Cisco887(config)#interface ATM 0
Cisco887(config-if)#description DSL Interface
Cisco887(config-if)#no ip address
Cisco887(config-if)#no ip redirects
Cisco887(config-if)#no ip unreachables
Cisco887(config-if)#no ip proxy-arp
Cisco887(config-if)#ip flow ingress
Cisco887(config-if)#no atm ilmi-keepalive
Cisco887(config-if)#pvc 8/35
Cisco887(config-atm-vc)#encapsulation aal5mux ppp dialer
Cisco887(config-atm-vc)#dialer pool-member 1
Cisco887(config-atm-vc)#no shutdown
Cisco887(config-atm-vc)#exit
!
Cisco887#conf t
Cisco887(config)#
Cisco887(config)#ip tcp synwait-time 10
Cisco887(config)#interface Null0
Cisco887(config)#interface Dialer0
Cisco887(config)#Description Connessione ad INTERNET (Alice 20 Mega)
Cisco887(config-if)#mtu 1492
Cisco887(config-if)#ip ddns update hostname camel.dyndns.org
Cisco887(config-if)#ip ddns update dyndns
Cisco887(config-if)#ip address negotiated
Cisco887(config-if)# ip nbar protocol-discovery
Cisco887(config-if)#ip flow ingress
Cisco887(config-if)#ip nat outside
Cisco887(config-if)#ip virtual-reassembly
Cisco887(config-if)#encapsulation ppp
Cisco887(config-if)#ip tcp adjust-mss 1248
Cisco887(config-if)#dialer pool 1
Cisco887(config-if)#dialer-group 1
Cisco887(config-if)#ipv6 address FE80::1 link-local
Cisco887(config-if)#ipv6 route 2000::/3 Dialer0
Cisco887(config-if)#ipv6 route ::/0 Dialer0
Cisco887(config-if)#ipv6 address autoconfig
Cisco887(config-if)#ipv6 enable
Cisco887(config-if)#ppp authentication chap callin
Cisco887(config-if)#ppp chap hostname aliceadsl
Cisco887(config-if)#ppp chap password 0 aliceadsl
Cisco887(config-if)#ppp pap sent-username aliceadsl password 0 aliceadsl
Cisco887(config-if)#no cdp enable
!
CONFIGURAZIONE NAT
Cisco887(config)#ip nat inside source static tcp 192.168.111.15 12000 interface Dialer0 12000
Cisco887(config)#ip nat inside source list 1 interface dialer 0 overload (Per impostare l’IP route dell’interfaccia di dialer come default Gateway)
Cisco887(config)#ip route 0.0.0.0 0.0.0.0 dialer 0 (Definisce ACCESS LIST)
Cisco887(config)#access-list 1 permit 192.168.111.0 0.0.0.255
Cisco887(config)#ip nat inside source static tcp 192.168.111.15 12000 interface Dialer0 12000
Cisco887(config)#ip nat inside source static udp 192.168.111.15 12000 interface Dialer0 12000
Cisco887(config)#ip nat inside source static tcp 192.168.111.10 4662 interface Dialer0 4662 eMule
Cisco887(config)#ip nat inside source static udp 192.168.111.10 4662 interface Dialer0 4662 eMule
Cisco887(config)#end
Cisco887#wr
Cisco887#copy run start
!
Cisco887(config)#interface ethernet 0
Cisco887(config-if)#
Cisco887(config-if)#ip nat inside
Cisco887(config-if)#no shutdown
Cisco887(config-if)#exit
Cisco887#
!
CONFIGURAZIONE DEI CODICI DI ACCESSO AL SERVIZIO Del Servizio ADSL
Cisco887(config)#int dialer 0
Cisco887(config-if)#ppp authentication chap callin
Cisco887(config-if)#ppp chap hostname aliceadsl
Cisco887(config-if)#ppp chap password aliceadsl
Cisco887(config-if)#ppp pap sent-username aliceadsl password aliceadsl
Cisco887(config-if)#exit
Cisco887#
Cisco887#conf t
Cisco887(config)#ip dns server
Cisco887(config)#ip name-server 4.2.2.6
Cisco887(config)#ip name-server 4.2.2.5
!
Cisco887(config)#ip inspect name SDM_LOW dns
Cisco887(config)#ip inspect name SDM_LOW ftp
Cisco887(config)#ip inspect name SDM_LOW h323
Cisco887(config)#ip inspect name SDM_LOW https
Cisco887(config)#ip inspect name SDM_LOW icmp
Cisco887(config)#ip inspect name SDM_LOW imap
Cisco887(config)#ip inspect name SDM_LOW pop3
Cisco887(config)#ip inspect name SDM_LOW netshow
Cisco887(config)#ip inspect name SDM_LOW rcmd
Cisco887(config)#ip inspect name SDM_LOW realaudio
Cisco887(config)#ip inspect name SDM_LOW rtsp
Cisco887(config)#ip inspect name SDM_LOW esmtp
Cisco887(config)#ip inspect name SDM_LOW sqlnet
Cisco887(config)#ip inspect name SDM_LOW streamworks
Cisco887(config)#ip inspect name SDM_LOW tftp
Cisco887(config)#ip inspect name SDM_LOW tcp router-traffic
Cisco887(config)#ip inspect name SDM_LOW udp router-traffic
Cisco887(config)#ip inspect name SDM_LOW vdolive
!
Cisco887(config)#access-list 101 permit tcp host 204.13.248.112 eq www any log
Cisco887(config)#ip ddns update camel.dyndns.org
Cisco887(config)#ip ddns update dyndns
Cisco887(config)#ip ddns update method dyndns
Cisco887(DDNS-update-method)#HTTP
Cisco887(DDNS-HTTP)#http://camel:12031952 @ blc.it @ members.dyndns.org/nic/update ? system=dyndns&hostname=camel.dyndns.org&myip=<a>)
DESCRIZIONE: Digitare fino alla @ per inserire la chiocciola ctrl-v e inserire il carattere( @ ) per inserire il ? ctrl-v e inserire il carattere ( ? )
Cisco887(DDNS-HTTP)#interval maximum 28 0 0 0
Cisco887(DDNS-update-method)#interface dialer0
!
Cisco887(config)#no cdp enable
Cisco887(config)#ip forward-protocol nd
Cisco887(config)#no ip http server
Cisco887(config)#ip http access-class 23
Cisco887(config)#ip http authentication local
Cisco887(config)#no ip http secure-server
Cisco887(config)#ip http access-class 23ip http timeout-policy idle 60 life 86400 requests 10000
!
IMPOSTAZIONE PASSWORD DI AMMINISTRATORE
Cisco887(config)#enable secret admin
!
IMPOSTAZIONE PASSWORD DI TELNET
Cisco887(config)#
Cisco887(config)#line vty 0 4
Cisco887(config-line)#password admin
Cisco887(config-line)#exit
Cisco887(config)#exit
Cisco887#
!
Secure access
SSH and HTTPS
!
Cisco887(config)# ip http secure-server
Cisco887(config)# ip http authentication local
Cisco887(config)# line vty 0 15
Cisco887(config)# login local
Cisco887(config-line)# transport input ssh
Cisco887(config-line)# transport output ssh
!
Nonsecure access
Telnet and HTTP
!
Cisco887(config)# ip http server
Cisco887(config)# ip http authentication local
Cisco887(config)# line vty 0 15
Cisco887(config)# login local
Cisco887(config-line)# transport input telnet
Cisco887(config-line)# transport output telnet
User privilege level
!
end
Grazie. :)
Forse Dio vuole che incontriamo un po’ di gente sbagliata prima di incontrare quella giusta, cosi quando finalmente la incontreremo... sapremo come essere riconoscenti per quel Regalo!
User avatar
cosibello
n00b
 
Posts: 7
Joined: Mon 05 May , 2014 10:13 pm
Location: Roma

Re: Config pronta per 857W: ADSL2 - DHCP - FW - DynDNS - WiF

Postby paolomat75 » Wed 11 Jun , 2014 8:30 am

Beh da 857 a 887 cambiano un po' di cose. Per il wireless guarda qua https://supportforums.cisco.com/discussion/11099516/cisco-887w-wlan-configuration.

Paolo
CCNA R&S and CCNP Route Pass - Studing....
Non cade foglia che l'inconscio non voglia (S.B.)
paolomat75
Messianic Network master
 
Posts: 2928
Joined: Fri 29 Jan , 2010 10:25 am
Location: Prov di GE

PreviousNext

Return to Configurazioni End User

Who is online

Users browsing this forum: No registered users and 3 guests