Codice: Seleziona tutto
Current configuration : 3304 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname [ROUTER NAME]
!
boot-start-marker
boot-end-marker
!
memory-size iomem 5
!
no aaa new-model
!
!
!
!
ip cef
ip domain name [NOME DOMINIO]
ip name-server 8.8.8.8 (QUESTI SONO DI GOOGLE)
ip name-server 8.8.4.4
no ip bootp server
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip ddns update method dyndns1
HTTP
add http://[USERNAME]:[PASSWORD]@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
remove http://[USERNAME]:[PASSWORD]@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
!
vpdn enable
!
!
!
!
username admin privilege 15 secret 5 $1$j1M8$MHOxMPjqHZ7C4aFyxwpH10
!
!
ip ssh time-out 15
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface Ethernet2
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
interface Dialer0
ip ddns update hostname [NOME HOST DYNDNS]
ip ddns update dyndns1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname [USERNAME]
ppp chap password 7 [PASSWORD]
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer0 overload
ip nat inside source static udp 192.168.0.5 1194 interface Dialer0 1194
ip nat inside source static tcp 192.168.0.5 2202 interface Dialer0 2202
ip nat inside source static tcp 192.168.0.5 82 interface Dialer0 82
!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
no cdp run
!
!
!
control-plane
!
banner motd ^C
_
.::::::::::. -(_)====u .::::::::::.
.::::''''''::::. .::::''''''::::.
.:::' `::::.... ....::::' `:::.
.::' `:::::::| |:::::::' `::.
.::| |::::::|_ ___ __|::::::| |::.
`--' |::::::|_()__()_|::::::| `--'
::: |::-o::| |::o-::| :::
`::. .|::::::| |::::::|. .::'
`:::. .::\-----' `-----/::. .:::'
`::::......::::' `::::......::::'
`::::::::::' `::::::::::'
This is the QSI International School of Brindisi Router
You are supposed to be here only if Authorized,
if you are not, please go away, all not authorized
accesses are logged and will be pursued by law.
^C
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line vty 0 4
exec-timeout 3 0
logging synchronous
login local
transport input ssh
!
scheduler max-task-time 5000
end
Allora, ecco cosa ritengo importante..
1) nella configurazione del dyndns, dovrete inserire il carattere ?
per farlo senza che l'IOS lo consider come un comando di HELP, premente prima CTRL+V quindi il ?
2) per username e password per accedere al router, dovrete ovviamente usare questo comando:
username [USERNAME] privilege 15 password 0 [PASSWORD]
3) le ACL sono per un Port Forwarding, le porte sono dirette all'ip locale 192.168.0.5, ovviamente cambierete porte e ip in base a quello che vi serve
4) la connessione e' PPPoE
molte persone, io in primis, avevano dei problemi nella navigazione internet, alcuni siti erano lentissimi da navigare o non caricare. il problema e' di MTU, che per il PPPoE e' di 1492, ma i pc, di default, utilizzano 1500 che e' la massima dimensione di un pacchetto ethernet.
togliere le limitazioni di MTU, non aiuta moltissimo, la soluzione e' invece di impostare il mss nel router, come potete vedere, il comando
ip tcp adjust-mss 1452
e' stato impostato nella eth0, ovvero nella interfaccia locale, con "ip nat inside"
spero possa essere utile