VPN Client PPTP su IOS

Virtual private networks e affini

Moderators: Federico.Lagni, Wizard, tonycimo, MaiO, CiscoBoy

VPN Client PPTP su IOS

Postby @lan72 » Mon 29 Sep , 2008 3:25 pm

Salve a tutti,
Pensavo di configurare una VPN Server su un Cisco 857W per uso casalingo, mi servirebbe esclusivamente per entrare sulla LAN di casa con il portatile collegato ad internet tramite modem UMTS quando sono fuori per lavoro e allo stesso tempo navigare.
Vi chiedevo per prima cosa se era possibile utilizzare la "connessione di accesso remoto vpn client microsoft" di WinXP per effettuare il collegamento verso il router, e che tipologia dovrei configurare per avere un collegamento in tutta sicurezza.

ho fatto un giro su questo forum... a parte le varie conf. mi è poco chiaro la tipologia da usare nel mio caso.

accetto link e consigli di ogni tipo :roll:
share your knowledge

.::.::. Cisco867VAE [IOS:15.4.3.M6a|FW:35j23je]
User avatar
@lan72
Cisco enlightened user
 
Posts: 157
Joined: Thu 22 May , 2008 4:36 pm
Location: Sicily

Postby Wizard » Mon 29 Sep , 2008 3:51 pm

Si sui router puoi ancora configurare le vpn pptp anche se nn te le consiglio
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
User avatar
Wizard
Intergalactic subspace network admin
 
Posts: 3441
Joined: Fri 03 Feb , 2006 10:04 am
Location: Emilia Romagna

Postby @lan72 » Mon 29 Sep , 2008 3:55 pm

Wizard wrote:Si sui router puoi ancora configurare le vpn pptp anche se nn te le consiglio


ciao Wizard perchè non non è consigliabile la pptp, in fondo mi serve solo per collegarmi alla lan di casa.

cosa mi consigli


p.s grazie sempre
share your knowledge

.::.::. Cisco867VAE [IOS:15.4.3.M6a|FW:35j23je]
User avatar
@lan72
Cisco enlightened user
 
Posts: 157
Joined: Thu 22 May , 2008 4:36 pm
Location: Sicily

Postby @lan72 » Tue 30 Sep , 2008 10:03 am

Salve spero possa essere d'aiuto.. leggendo quà e là ho adattato questa conf per una VPN semlice in PPTP.


C857W(config)# vpdn enable
C857W(config)# vpdn-group C857W-VPN
C857W(config-vpdn)# accept-dialin
C857W(config-vpdn)# protocol pptp
C857W(config-vpdn)# virtual-template 1
C857W(config-vpdn)# exit

C857W(config)# interface Virtual-Template1
C857W(config-if)# ip unnumbered BVI1
C857W(config-if)# peer default ip address pool VPN
C857W(config-if)# ppp encrypt mppe auto required
C857W(config-if)# ppp authentication ms-chap ms-chap-v2
C857W(config-if)# exit

Router(config)# ip local pool VPN 192.168.1.220 192.168.1.220
Router(config)# username pippo password 0 pippo



Naturalmente dovrei creare le ACL

access-list 101 permit tcp any any eq 1723



e la nat sulla porta 1723 (il router ha ip locale 192.168.0.221)

ip nat inside source static tcp 192.168.0.221 1723 interface Dialer0 1723



Le mie perplessità sono:

In teoria mi dovrei collegare con una VPN Client Microsoft, ma riuscirei a navigare allo stesso tempo ???

Come posso fare per dare al client VPN i DNS e il dominio ???

Infine dal momento che ho configurato una VPN su BVI1 è corretto così ???

Potrei eventualmente rilasciare l'IP VPN al client sempre nello stesso range della BVI1 cambiandolo così:

Router(config)# ip local pool VPN 192.168.0.220 192.168.0.220


L'IP della BVI1 è 192.168.0.221 - 255.255.255.0


Saluti
Agostino
share your knowledge

.::.::. Cisco867VAE [IOS:15.4.3.M6a|FW:35j23je]
User avatar
@lan72
Cisco enlightened user
 
Posts: 157
Joined: Thu 22 May , 2008 4:36 pm
Location: Sicily

Postby Wizard » Tue 30 Sep , 2008 11:01 am

Code: Select all
In teoria mi dovrei collegare con una VPN Client Microsoft, ma riuscirei a navigare allo stesso tempo ???


Devi togliere il flag da "usa gateway predefinito sulla rete remota" dalla connessione vpn.
Il futuro è fatto di persone che hanno delle intuizioni e visioni .....sono quelle persone che fanno la differenza...... quelle dotate di un TERZO OCCHIO....
User avatar
Wizard
Intergalactic subspace network admin
 
Posts: 3441
Joined: Fri 03 Feb , 2006 10:04 am
Location: Emilia Romagna

Postby biapar » Thu 04 Dec , 2008 9:10 am

Salve,

il mio router non permette il comando:

ppp encrypt mppe auto required

Penso che sia errato l'IOS. La versione è:

Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(15)T7, RE

Ho necessità dell'ADVIPSERVICES?

Grazie
biapar
n00b
 
Posts: 3
Joined: Thu 04 Dec , 2008 9:06 am

Postby masterx81 » Thu 18 Dec , 2008 10:31 am

Io la vpn pptp sono riuscito a farla pure un vecchissimo router ISDN 1603... Figurati!
Certo, non ho abilitato la crittografia, che non è una cosa bellissima... Pero' va alla grande!
Se ti puo' interessare, questa è la config per fare la vpn in pptp senza crittografia (che a quanto pare la tua ios non permette):
Code: Select all
aaa new-model
aaa authentication ppp VPNDialIn local
aaa authorization network default if-authenticated

username UTENTE password PASSWORD

virtual-profile virtual-template 1
virtual-profile aaa
vpdn enable
!
vpdn-group VPNDialIn
! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1
!

interface Virtual-Template1
 ip unnumbered Ethernet0
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 no keepalive
 peer default ip address pool VPNIN
 ppp authentication ms-chap callin VPNDialIn
!

ip local pool VPNIN 192.168.200.200 192.168.200.205




Dovrebbe esserci tutto
le porte da aprire dovrebbero essere:

Code: Select all
access-list 100 permit tcp any any eq 1723
access-list 100 permit udp any eq isakmp any eq isakmp
access-list 100 permit gre any any


e questo dovrebbe essere tutto

Se volessi mettere la crittografia, dovresti procurarti una ios piu' decente.
Io con degli 857w ho fatto un po' di tutto con a ios giusta... Si sta un po' stretti, ma vanno egregiamente (ho un tunnel ipsec su da ormai almeno 1 anno senza rogne - l'ultima rogna era un buco nella ios :-) )
masterx81
Cisco enlightened user
 
Posts: 154
Joined: Wed 20 Jun , 2007 11:20 am


Return to VPN

Who is online

Users browsing this forum: No registered users and 3 guests