VPN server ipsec con nat traversal e problemi split tunnelin

Virtual private networks e affini

Moderators: Federico.Lagni, Wizard, tonycimo, MaiO, CiscoBoy

VPN server ipsec con nat traversal e problemi split tunnelin

Postby giankyfava » Mon 10 Dec , 2018 10:51 am

Salve,
vi espongo il mio problema... ho un'ASA 5506-X su cui ho configurato un vpn server ipsec sotto nat utilizzando la funzione isakmp nat traversal. Il router che fa nat è un router Tim modello sercomm (ip lan 192.168.0.1), con firewall disabilitato e funzione 'dmz' del router attiva per l'ip del della wan del firewall (192.168.0.254). Riesco a connettermi in vpn e raggiungere la lan remota senza problemi, tuttavia una volta connesso non vedo più la lan locale nè riesco a navigare. Penso si tratti di un problema di split tunneling. Aggiungo che con la stessa configurazione ma esponendo direttamente il firewall con un ip pubblico non ha alcun problema. Avete qualche idea?

Intanto posto la mia configurazione:

Code: Select all
ASA Version 9.8(2)
!
hostname *********
enable password *****
passwd ***** encrypted
names
ip local pool VPNPOOL 10.0.3.171-10.0.3.174 mask 255.255.255.0

!
interface GigabitEthernet1/1
 nameif outside
 security-level 0
 ip address 192.168.0.254 255.255.255.0
!
interface GigabitEthernet1/2
 nameif inside
 security-level 100
 ip address 10.0.3.254 255.255.255.0
!
interface GigabitEthernet1/3
 no nameif
 security-level 100
 no ip address
!
interface GigabitEthernet1/4
 no nameif
 security-level 100
 no ip address
!
interface GigabitEthernet1/5
 no nameif
 security-level 100
 no ip address
!
interface GigabitEthernet1/6
 no nameif
 security-level 100
 no ip address
!
interface GigabitEthernet1/7
 no nameif
 security-level 100
 no ip address
!
interface GigabitEthernet1/8
 no nameif
 security-level 100
 no ip address
!
interface Management1/1
 management-only
 no nameif
 no security-level
 no ip address
!
ftp mode passive
object network LAN
 subnet 10.0.3.0 255.255.255.0
object network obj-ALL
 subnet 0.0.0.0 0.0.0.0
object network obj-linuxsrv_old
 host 10.0.3.194
access-list OUTSIDE extended permit ip any any
access-list OUTSIDE extended permit tcp any host 10.0.3.194 eq ssh
access-list split_tunnel_acl standard permit 10.0.3.0 255.255.255.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 16384
nat (inside,outside) source static LAN LAN destination static LAN LAN
!
object network obj-ALL
 nat (inside,outside) dynamic interface
object network obj-linuxsrv_old
 nat (inside,outside) static interface service tcp ssh 2222
access-group OUTSIDE in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication ssh console LOCAL
aaa authentication login-history
no snmp-server location
no snmp-server contact
service sw-reset-button
crypto ipsec ikev1 transform-set HIGH esp-aes-256 esp-sha-hmac
crypto ipsec security-association pmtu-aging infinite
crypto dynamic-map vpnclient 65535 set ikev1 transform-set HIGH
crypto map castelnuovo 65535 ipsec-isakmp dynamic vpnclient
crypto map castelnuovo interface outside
crypto ca trustpoint SSL-SELF
 enrollment self
 fqdn ****
 subject-name CN=****
 keypair SSL-Keypair
 crl configure
crypto ca trustpoint SSL-Keypair
 enrollment terminal
 fqdn ****
 subject-name ***
 serial-number
 keypair SSL-Keypair
 crl configure
crypto ca trustpoint localtrust
 enrollment self
 fqdn ****
 subject-name ****
 keypair SSL-Keypair
 crl configure
crypto ca trustpool policy
crypto isakmp identity address
crypto isakmp nat-traversal 3600
crypto isakmp disconnect-notify
crypto isakmp reload-wait
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh stricthostkeycheck
ssh ********* 255.255.255.255 outside
ssh 10.0.3.0 255.255.255.0 inside
ssh timeout 10
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd dns 8.8.8.8 8.8.4.4
dhcpd lease 86400
!
dhcpd address 10.0.3.175-10.0.3.189 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 anyconnect image disk0:/anyconnect-win-4.4.00243-webdeploy-k9.pkg 1
 tunnel-group-list enable
 cache
  disable
 error-recovery disable
group-policy SSL_POLICY internal
group-policy SSL_POLICY attributes
 vpn-tunnel-protocol ssl-client ssl-clientless
 address-pools value VPNPOOL
 webvpn
  anyconnect keep-installer installed
group-policy VPNCLIENTPOLICY internal
group-policy VPNCLIENTPOLICY attributes
 vpn-tunnel-protocol ikev1
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split_tunnel_acl
dynamic-access-policy-record DfltAccessPolicy
username ***** password ******* privilege 15
tunnel-group SSLCLIENT type remote-access
tunnel-group SSLCLIENT general-attributes
 address-pool VPNPOOL
tunnel-group SSLCLIENT webvpn-attributes
 group-alias ******* enable
tunnel-group VPNCLIENT type remote-access
tunnel-group VPNCLIENT general-attributes
 address-pool VPNPOOL
tunnel-group VPNCLIENT ipsec-attributes
 ikev1 pre-shared-key *****
 isakmp keepalive threshold 15 retry 10
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
  no tcp-inspection
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
: end


Grazie.
giankyfava
Cisco power user
 
Posts: 76
Joined: Tue 28 Dec , 2004 10:33 am

Return to VPN

Who is online

Users browsing this forum: No registered users and 4 guests

cron