http://www.ie.itcr.ac.cr/egarcia/Presen ... yCCNP1.pdf
interessante come il documento stesso propone una soluzione (configurazione mostrata alla fine) e come io ne abbia usata un'altra, che io penso essere equivalente se non da preferire (in quanto più vicina a quello descritto nel libro.. )
allego le mie configurazioni (parte relative alla soluzione del problema) ed alcuni show che mostrano tutto sia funzionante.
Il mio obbiettivo e dare a chi sta studiando come me, un punto di vista diverso, e far comprendere come soluzioni apparantemente diverse possano invece essere molto simili se non uguali nei risultati:
SanJose3
Codice: Seleziona tutto
hostname SanJose3
!
interface Loopback0
ip address 192.168.1.3 255.255.255.0
ip ospf 1 area 0
!
interface Serial0/0
ip address 192.168.192.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
ip ospf 1 area 0
frame-relay interface-dlci 102
frame-relay interface-dlci 103
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
!
Codice: Seleziona tutto
hostname London
!
interface Loopback0
ip address 192.168.200.1 255.255.255.0
ip ospf 1 area 0
!
interface Serial0/0
ip address 192.168.192.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
ip ospf 1 area 0
frame-relay map ip 192.168.192.4 201 broadcast
frame-relay interface-dlci 201
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
!
Codice: Seleziona tutto
hostname Singapore
!
interface Loopback0
ip address 192.168.232.1 255.255.255.0
ip ospf 1 area 0
!
interface Serial0/0
ip address 192.168.192.4 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
ip ospf 1 area 0
frame-relay map ip 192.168.192.2 301 broadcast
frame-relay interface-dlci 301
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
!
Rispetto alla soluzione mostrato nel documento questi sono i miei cambiamenti:
1) ho assegnato manualmente un router-id
2) ho abilitato l'ospf sull'interfaccia e non tramite "router ospf process_id"
3) ho usato il frame-relay Inverse Arp per ogni PVC direttamente connesso
4) ho usato il map manuale IP-DLCI (con l'opzione broadcast) solo per i router che devo raggiungere ma che non sono direttamente connessi tramite PVC
Ricordandovi che OSPF forma adiacenze solo per router direttamente connessi da PVC ecco alcuni show:
Codice: Seleziona tutto
SanJose3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:01:57 192.168.192.4 Serial0/0
2.2.2.2 0 FULL/ - 00:01:52 192.168.192.2 Serial0/0
SanJose3#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 396 0x80000005 0x00DA9B 4
2.2.2.2 2.2.2.2 456 0x80000004 0x00FD33 3
3.3.3.3 3.3.3.3 396 0x80000004 0x001EE6 3
SanJose3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.192.0/24 is variably subnetted, 3 subnets, 2 masks
C 192.168.192.0/24 is directly connected, Serial0/0
O 192.168.192.2/32 [110/64] via 192.168.192.2, 00:07:14, Serial0/0
O 192.168.192.4/32 [110/64] via 192.168.192.4, 00:07:14, Serial0/0
192.168.200.0/32 is subnetted, 1 subnets
O 192.168.200.1 [110/65] via 192.168.192.2, 00:07:14, Serial0/0
192.168.232.0/32 is subnetted, 1 subnets
O 192.168.232.1 [110/65] via 192.168.192.4, 00:07:14, Serial0/0
C 192.168.1.0/24 is directly connected, Loopback0
Codice: Seleziona tutto
London#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:01:45 192.168.192.1 Serial0/0
London#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 301 0x80000005 0x00DA9B 4
2.2.2.2 2.2.2.2 360 0x80000004 0x00FD33 3
3.3.3.3 3.3.3.3 301 0x80000004 0x001EE6 3
London#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.192.0/24 is variably subnetted, 3 subnets, 2 masks
C 192.168.192.0/24 is directly connected, Serial0/0
O 192.168.192.1/32 [110/64] via 192.168.192.1, 00:09:36, Serial0/0
O 192.168.192.4/32 [110/128] via 192.168.192.1, 00:09:36, Serial0/0
C 192.168.200.0/24 is directly connected, Loopback0
192.168.232.0/32 is subnetted, 1 subnets
O 192.168.232.1 [110/129] via 192.168.192.1, 00:09:36, Serial0/0
192.168.1.0/32 is subnetted, 1 subnets
O 192.168.1.3 [110/65] via 192.168.192.1, 00:09:36, Serial0/0
Codice: Seleziona tutto
Singapore#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:01:38 192.168.192.1 Serial0/0
Singapore#show ip ospf database
OSPF Router with ID (3.3.3.3) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 357 0x80000005 0x00DA9B 4
2.2.2.2 2.2.2.2 416 0x80000004 0x00FD33 3
3.3.3.3 3.3.3.3 355 0x80000004 0x001EE6 3
Singapore#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.192.0/24 is variably subnetted, 3 subnets, 2 masks
C 192.168.192.0/24 is directly connected, Serial0/0
O 192.168.192.1/32 [110/64] via 192.168.192.1, 00:08:30, Serial0/0
O 192.168.192.2/32 [110/128] via 192.168.192.1, 00:08:30, Serial0/0
192.168.200.0/32 is subnetted, 1 subnets
O 192.168.200.1 [110/129] via 192.168.192.1, 00:08:30, Serial0/0
C 192.168.232.0/24 is directly connected, Loopback0
192.168.1.0/32 is subnetted, 1 subnets
O 192.168.1.3 [110/65] via 192.168.192.1, 00:08:30, Serial0/0
Codice: Seleziona tutto
London#ping 192.168.232.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.232.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/48 ms
London#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Singapore#ping 192.168.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Singapore#ping 192.168.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/26/36 ms