Pagina 1 di 1

Problemi PPP over Frame Relay

Inviato: lun 25 feb , 2008 10:45 pm
da lemonade
Ciao a tutti,
sono due giorni che sbatto la testa su un problema e non riesco a venirne a capo.
La situazione è la seguente: rete Frame Relay hub and spoke (1 hub e 3 spoke), tutte le sedi con router DIGICOM Tintoretto FRAD.
Uno dei router spoke si è fuso, il cliente ha acquistato un Cisco 1841 con WIC-1T e mi ha incaricato della sostituzione.
Guardando la configurazione del DIGICOM della sede centrale e di quelli periferici, mi sono accorto che usano sotto-interfacce punto-punto unnumbered ed è utilizzato il protocollo PPP over Frame Relay.
Quella che segue è la configurazione che ho buttato giù:

Codice: Seleziona tutto

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname GIBICAR
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$2BpB$dwhMjqQP9PpJDrVMRYbqF.
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip domain lookup
!
!
!
!
interface FastEthernet0/0
 ip address 11.0.0.200 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 frame-relay interface-dlci 20 ppp Virtual-Template1
!
interface Virtual-Template1 
 ip unnumbered FastEthernet0/0
!
ip classless
!
ip http server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 password 7 03165409031D3543400C
 logging synchronous
 login
line aux 0
line vty 0 4
 password 7 0833434C0C0B11181C0E
 login
!
end
Di seguito l'output di alcuni comandi di show e debug tramite i quali mi sono accorto che il PVC Frame relay viene correttamente instaurato fra i due router, ma che evidentemente c'è qualcosa che impedisce la negoziazione del link da parte del protocollo PPP:

Codice: Seleziona tutto

GIBICAR#sh ip int brie

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            11.0.0.200      YES manual up                    up      
FastEthernet0/1            unassigned      YES unset  administratively down down    
Serial0/0/0                unassigned      YES unset  up                    up      
Serial0/0/0.1              unassigned      YES manual up                    up      
Virtual-Access1            11.0.0.200      YES TFTP   up                    down    
Virtual-Template1          11.0.0.200      YES TFTP   down                  down    
Virtual-Access2            unassigned      YES unset  down                  down    

Codice: Seleziona tutto

GIBICAR#sh int

FastEthernet0/0 is up, line protocol is up 
  Hardware is Gt96k FE, address is 001b.d50f.4aac (bia 001b.d50f.4aac)
  Internet address is 11.0.0.200/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 1 packets/sec
     1590 packets input, 136742 bytes
     Received 343 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1842 packets output, 147536 bytes, 0 underruns
     0 output errors, 0 collisions, 7 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Serial0/0/0 is up, line protocol is up 
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  413, LMI stat recvd 403, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 84/3, interface broadcasts 0
  Last input 00:00:09, output 00:00:01, output hang never
  Last clearing of "show interface" counters 01:46:55
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     420 packets input, 6751 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     8 input errors, 8 CRC, 3 frame, 1 overrun, 0 ignored, 4 abort
     745 packets output, 38292 bytes, 0 underruns
     0 output errors, 0 collisions, 77 interface resets
     0 output buffer failures, 0 output buffers swapped out
     13 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Serial0/0/0.1 is up, line protocol is up 
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY
  Last clearing of "show interface" counters never

Virtual-Access1 is up, line protocol is down 
  Hardware is Virtual Access interface
  Interface is unnumbered. Using address of FastEthernet0/0 (11.0.0.200)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  PPPoFR vaccess, cloned from Virtual-Template1
  Vaccess status 0x44
  Bound to Serial0/0/0.1 DLCI 20, Cloned from Virtual-Template1, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Last input 00:00:01, output never, output hang never
  Last clearing of "show interface" counters 00:23:09
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     377 packets input, 12731 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     157 packets output, 1570 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

Virtual-Template1 is down, line protocol is down 
  Hardware is Virtual Template interface
  Interface is unnumbered. Using address of FastEthernet0/0 (11.0.0.200)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:23:11
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

Codice: Seleziona tutto

GIBICAR#sh frame-relay pvc

PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 20, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.1

  input pkts 16            output pkts 172          in bytes 720       
  out bytes 9169           dropped pkts 0           in pkts dropped 0         
  out pkts dropped 0                out bytes dropped 0         
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0         
  out BECN pkts 0          in DE pkts 0             out DE pkts 0         
  out bcast pkts 19        out bcast bytes 5851      
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:22:46, last time pvc status changed 00:00:40
  Bound to Virtual-Access1 (down, cloned from Virtual-Template1)

Codice: Seleziona tutto

GIBICAR#debug ppp negotiation

*Feb 25 18:30:49.099: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Feb 25 18:30:49.103: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Feb 25 18:30:49.103: Vi1 PPP: Using default call direction
*Feb 25 18:30:49.103: Vi1 PPP: Treating connection as a dedicated line
*Feb 25 18:30:49.103: Vi1 PPP: Session handle[78000008] Session id[3]
*Feb 25 18:30:49.103: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Feb 25 18:30:49.103: Vi1 LCP: O CONFREQ [Closed] id 135 len 10
*Feb 25 18:30:49.103: Vi1 LCP:    MagicNumber 0x1C3D41F7 (0x05061C3D41F7)
*Feb 25 18:30:49.119: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Feb 25 18:30:49.119: Vi1 PPP: Sending Acct Event[Down] id[5]
*Feb 25 18:30:49.119: Vi1 LCP: State is Closed
*Feb 25 18:30:49.119: Vi1 PPP: Phase is DOWN
*Feb 25 18:30:50.099: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
*Feb 25 18:30:50.107: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Feb 25 18:30:50.107: Vi1 PPP: Using default call direction
*Feb 25 18:30:50.107: Vi1 PPP: Treating connection as a dedicated line
*Feb 25 18:30:50.107: Vi1 PPP: Session handle[18000009] Session id[4]
*Feb 25 18:30:50.107: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Feb 25 18:30:50.107: Vi1 LCP: O CONFREQ [Closed] id 136 len 10
*Feb 25 18:30:50.107: Vi1 LCP:    MagicNumber 0x1C3D45E4 (0x05061C3D45E4)
*Feb 25 18:30:52.115: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:30:52.115: Vi1 LCP: O CONFREQ [REQsent] id 137 len 10
*Feb 25 18:30:52.115: Vi1 LCP:    MagicNumber 0x1C3D45E4 (0x05061C3D45E4)
*Feb 25 18:30:54.131: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:30:54.131: Vi1 LCP: O CONFREQ [REQsent] id 138 len 10
*Feb 25 18:30:54.131: Vi1 LCP:    MagicNumber 0x1C3D45E4 (0x05061C3D45E4)
*Feb 25 18:30:56.147: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:30:56.147: Vi1 LCP: O CONFREQ [REQsent] id 139 len 10
*Feb 25 18:30:56.147: Vi1 LCP:    MagicNumber 0x1C3D45E4 (0x05061C3D45E4)
*Feb 25 18:30:58.163: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:30:58.163: Vi1 LCP: O CONFREQ [REQsent] id 140 len 10
*Feb 25 18:30:58.163: Vi1 LCP:    MagicNumber 0x1C3D45E4 (0x05061C3D45E4)
*Feb 25 18:30:59.107: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Feb 25 18:30:59.107: Vi1 PPP: Sending Acct Event[Down] id[6]
*Feb 25 18:30:59.107: Vi1 LCP: State is Closed
*Feb 25 18:30:59.107: Vi1 PPP: Phase is DOWN
*Feb 25 18:31:59.115: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Feb 25 18:31:59.115: Vi1 PPP: Using default call direction
*Feb 25 18:31:59.115: Vi1 PPP: Treating connection as a dedicated line
*Feb 25 18:31:59.115: Vi1 PPP: Session handle[CC00000A] Session id[5]
*Feb 25 18:31:59.115: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Feb 25 18:31:59.115: Vi1 LCP: O CONFREQ [Closed] id 141 len 10
*Feb 25 18:31:59.115: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:01.107: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:01.107: Vi1 LCP: O CONFREQ [REQsent] id 142 len 10
*Feb 25 18:32:01.107: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:03.123: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:03.123: Vi1 LCP: O CONFREQ [REQsent] id 143 len 10
*Feb 25 18:32:03.123: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:05.139: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:05.139: Vi1 LCP: O CONFREQ [REQsent] id 144 len 10
*Feb 25 18:32:05.139: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:07.155: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:07.155: Vi1 LCP: O CONFREQ [REQsent] id 145 len 10
*Feb 25 18:32:07.155: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:09.171: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:09.171: Vi1 LCP: O CONFREQ [REQsent] id 146 len 10
*Feb 25 18:32:09.171: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:11.187: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:11.187: Vi1 LCP: O CONFREQ [REQsent] id 147 len 10
*Feb 25 18:32:11.187: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:13.203: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:13.203: Vi1 LCP: O CONFREQ [REQsent] id 148 len 10
*Feb 25 18:32:13.203: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:15.219: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:15.219: Vi1 LCP: O CONFREQ [REQsent] id 149 len 10
*Feb 25 18:32:15.219: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:17.235: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:17.235: Vi1 LCP: O CONFREQ [REQsent] id 150 len 10
*Feb 25 18:32:17.235: Vi1 LCP:    MagicNumber 0x1C3E5375 (0x05061C3E5375)
*Feb 25 18:32:19.251: Vi1 LCP: TIMEout: State REQsent
*Feb 25 18:32:19.251: Vi1 LCP: State is Listen
Chiedo scusa a tutti per la lunghezza del post ma ho voluto fornire più dettagli possibile affinchè magari qualcuno di voi si accorga di ciò che a me sfugge.

Inviato: mar 26 feb , 2008 11:32 pm
da Renato.Efrati
la sede centrale fa ip unnumbered su quale interfaccia e con che indirizzo ci posti anche la centrale?

e poi comunque nn vedo i parametri del ppp sotto il virtual-template e nessun username col quale authenticarsi scommetto che se fai un debug ppp authentication hai errorri a nn finire vero?

Inviato: mar 04 mar , 2008 4:29 pm
da lemonade
sul router centrale non è stato abilitato nessun metodo di autenticazione, nè PAP ne CHAP, ma solamente il protocollo di encapsulation ppp. Nel virtual-template non si vede nulla perchè l'encapsulation ppp è settata di default. Comunque appena possibile posto la configurazione del Digicom.
Grazie sin da ora per l'interessamento.