Pagina 1 di 1

DHCP con più di 1 pool

Inviato: dom 12 ago , 2007 9:16 pm
da matcy
finché configuro 1 pool solo tutto va bene, quando aggiungo il secondo non mi viene assegnato l'ip su nessuna delle 2 interfacce.
vlan11 192.168.11.0/24
vlan3 192.168.13.0/24

sicuramente mi manca un pezzo nel ragionamento...

Codice: Seleziona tutto

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname jamez
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 xxxxxxxx
!
no aaa new-model
clock timezone PCTime 1
clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
!
crypto ........
! 
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.11.1 192.168.11.100
ip dhcp excluded-address 192.168.11.200 192.168.11.254
ip dhcp excluded-address 192.168.13.1 192.168.13.100
ip dhcp excluded-address 192.168.13.200 192.168.13.254
!
ip dhcp pool LAN
   import all
   network 192.168.11.0 255.255.255.0
   domain-name xxxxxxxxxxxxxx
   dns-server 194.243.154.62 212.216.112.112 
   default-router 192.168.11.1 
   netbios-name-server 192.168.11.12 
!
ip dhcp pool altro
   import all
   network 192.168.13.0 255.255.255.0
   dns-server 194.243.154.62 212.216.112.112 
   default-router 192.168.13.1 
!
!
ip name-server 212.216.112.112
ip name-server 151.99.125.1
ip name-server 151.99.0.100
ip name-server 212.216.172.62
ip name-server 194.243.154.62
ip name-server 212.131.30.42
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto 
!
interface ATM0.1 point-to-point
 no snmp trap link-status
 pvc 8/35 
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
 switchport access vlan 11
!
interface FastEthernet1
 description LAN
 switchport access vlan 11
!
interface FastEthernet2
 description Public
 switchport access vlan 2
!
interface FastEthernet3
 description altro
 switchport access vlan 3
!
interface Vlan1
 no ip address
!
interface Vlan11
 description LAN
 ip address 192.168.11.1 255.255.255.0
 ip access-group sdm_vlan11_in in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Vlan2
 description Public
 ip address 192.168.12.1 255.255.255.252
 ip access-group sdm_vlan2_in in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Vlan3
 description altro
 ip address 192.168.13.1 255.255.255.0
 ip access-group sdm_vlan3_in in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Dialer0
 ip address negotiated
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname xxxxxxxxxx
 ppp chap password 0 xxxxxxxxxxxx
 ppp pap sent-username xxxxxxxxx password 0 xxxxxxxxxxx
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source list 2 interface Dialer0 overload
ip nat inside source static tcp 192.168.12.2 80 interface Dialer0 80
ip nat inside source static tcp 192.168.12.2 22 interface Dialer0 23
ip nat inside source static tcp 192.168.12.2 20 interface Dialer0 20
ip nat inside source static tcp 192.168.12.2 21 interface Dialer0 21
ip nat inside source list 3 interface Dialer0 overload
ip nat inside source static tcp 192.168.12.2 22 interface Dialer0 22
!
ip access-list extended sdm_vlan11_in
 remark SDM_ACL Category=1
 remark LAN->WAN
 permit ip 192.168.11.0 0.0.0.255 any
ip access-list extended sdm_vlan2_in
 remark SDM_ACL Category=1
 remark Public->LAN
 deny   ip 192.168.12.0 0.0.0.3 192.168.11.0 0.0.0.255
 remark Public->WAN
 permit ip 192.168.12.0 0.0.0.3 any
ip access-list extended sdm_vlan3_in
 remark SDM_ACL Category=1
 remark altro->LAN
 deny   ip 192.168.13.0 0.0.0.255 192.168.11.0 0.0.0.255
 remark altro->Public
 deny   ip 192.168.13.0 0.0.0.255 192.168.12.0 0.0.0.3
 remark altro->WAN
 permit ip 192.168.13.0 0.0.0.255 any
!
access-list 1 remark INSIDE_IF=Vlan11
access-list 1 permit 192.168.11.0 0.0.0.255
access-list 2 remark INSIDE_IF=Vlan2
access-list 2 permit 192.168.12.0 0.0.0.3
access-list 3 remark INSIDE_IF=Vlan3
access-list 3 permit 192.168.13.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
 transport input ssh
!
scheduler max-task-time 5000

!
webvpn cef
end