Pagina 1 di 1

HSRP State Continuously Changes

Inviato: mar 15 ott , 2019 7:02 am
da clark
Hi all,
please I need urgent support from you.
I'm encountering following issue in a scenario similar to the attached one, in which I configured two rings (Ring1A and Ring1B) using REP protocol.
I use vlan 101 for Ring1A and vlan 201 for Ring1B configured as shown below:

Central Switch_A
...
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan 40
name X1_A
!
vlan 41
name X2_A
!
vlan 101
name Ring1_A
!
vlan 140
name X1_B
!
vlan 141
name X2_B
!
vlan 201
name Ring1_B
!
...
interface GigabitEthernet7/1
description --- REP101 Ring1A to Switch 1A---
switchport trunk allowed vlan 40,41,101
switchport mode trunk
rep segment 101 edge primary
!
interface GigabitEthernet8/2
description --- Edge Port Primary for Rep101 Ring1A ---
switchport trunk allowed vlan 101
switchport mode trunk
rep segment 101 edge primary
rep preempt delay 15
rep block port id 040100D78F8B5A00 vlan 1-4094
!
interface GigabitEthernet9/1
description --- REP201 Ring1B to Switch1B ---
switchport trunk allowed vlan 140,141,201
switchport mode trunk
rep segment 201
!
interface GigabitEthernet10/2
description --- Edge Port for Rep201 Ring1B ---
switchport trunk allowed vlan 201
switchport mode trunk
rep segment 201
!
interface Vlan40
description --- X1_A ---
ip address 172.16.63.252 255.255.248.0
standby version 2
standby 0 ip 172.16.63.254
standby 0 timers msec 700 3
standby 0 priority 255
standby 0 preempt
!
interface Vlan41
description --- X2_A ---
ip address 172.16.51.252 255.255.254.0
standby version 2
standby 0 ip 172.16.51.254
standby 0 timers msec 700 3
standby 0 priority 255
standby 0 preempt
!
interface Vlan101
description --- GW_Ring1_A ---
ip address 172.27.65.252 255.255.255.0
standby version 2
standby 0 ip 172.27.65.254
standby 0 timers msec 700 3
standby 0 priority 255
standby 0 preempt
!
interface Vlan140
description --- X1_B ---
ip address 172.24.63.252 255.255.248.0
standby version 2
standby 0 ip 172.24.63.254
!
interface Vlan141
description --- X2_B ---
ip address 172.24.51.252 255.255.254.0
standby version 2
standby 0 ip 172.24.51.254
!
interface Vlan201
description ---GW_Ring1_B ---
ip address 172.27.129.252 255.255.255.0
standby version 2
standby 0 ip 172.27.129.254
!


Central Switch_B
...

spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan 40
name X1_A
!
vlan 41
name X2_A
!
vlan 101
name Ring1_A
!
vlan 140
name X1_B
!
vlan 141
name X2_B
!
vlan 201
name Ring1_B
!
...
interface GigabitEthernet7/1
description --- REP101 Ring1A to Switch 1A---
switchport trunk allowed vlan 40,41,101
switchport mode trunk
rep segment 101 edge primary
!
interface GigabitEthernet8/2
description --- Edge Port Primary for Rep101 Ring1A ---
switchport trunk allowed vlan 101
switchport mode trunk
rep segment 101 edge primary
rep preempt delay 15
rep block port id 040100D78F8B5A00 vlan 1-4094
!
interface GigabitEthernet9/1
description --- REP201 Ring1B to Switch1B ---
switchport trunk allowed vlan 140,141,201
switchport mode trunk
rep segment 201
!
interface GigabitEthernet10/2
description --- Edge Port for Rep201 Ring1B ---
switchport trunk allowed vlan 201
switchport mode trunk
rep segment 201
!
interface Vlan40
description --- X1_A ---
ip address 172.16.63.253 255.255.248.0
standby version 2
standby 0 ip 172.16.63.254
!
interface Vlan41
description --- X2_A ---
ip address 172.16.51.253 255.255.254.0
standby version 2
standby 0 ip 172.16.51.254
!
interface Vlan101
description --- GW_Ring1_A ---
ip address 172.27.65.253 255.255.255.0
standby version 2
standby 0 ip 172.27.65.254
!
interface Vlan140
description --- X1_B ---
ip address 172.24.63.253 255.255.248.0
standby version 2
standby 0 ip 172.24.63.254
standby 0 timers msec 700 3
standby 0 priority 255
standby 0 preempt
!
interface Vlan141
description --- X2_B ---
ip address 172.24.51.253 255.255.254.0
standby version 2
standby 0 ip 172.24.51.254
standby 0 timers msec 700 3
standby 0 priority 255
standby 0 preempt
!
interface Vlan201
description ---GW_Ring1_B ---
ip address 172.27.129.253 255.255.255.0
standby version 2
standby 0 ip 172.27.129.254
standby 0 timers msec 700 3
standby 0 priority 255
standby 0 preempt
!

Switch1_A

...
vlan 40
name X1_A
!
vlan 41
name X2_A
!
vlan 101
name Ring1A
interface GigabitEthernet0/15
port-type nni
switchport trunk allowed vlan 40,41,101
switchport mode trunk
rep segment 101
!
interface GigabitEthernet0/16
port-type nni
switchport trunk allowed vlan 40,41,101
switchport mode trunk
rep segment 101
!
interface Vlan101
ip address 172.27.65.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 172.27.65.254

Switch1_B

vlan 140
name X1_B
!
vlan 141
name X2_B
!
vlan 201
name Ring1B

interface GigabitEthernet0/15
port-type nni
switchport trunk allowed vlan 140,141,201
switchport mode trunk
rep segment 201
!
interface GigabitEthernet0/16
port-type nni
switchport trunk allowed vlan 140,141,201
switchport mode trunk
rep segment 201
!
interface Vlan201
ip address 172.27.129.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 172.27.129.254

Now, if I do not set "Allowed vlan 40,41" on trunk port 0/15 and/or 0/16 of switch Switch1_A (and similarly vlan allowed 140,141 on trunk port 0/15 and/or 0/16 of switch1_B) sh standby brief command shows next clear output:

#sh standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Vl40 0 255 P Active local 172.16.63.253 172.16.63.254
Vl41 0 255 P Active local 172.16.51.253 172.16.51.254
Vl101 0 255 P Active local 172.27.65.253 172.27.65.254
Vl140 0 100 Standby 172.24.63.253 local 172.24.63.254
Vl141 0 100 Standby 172.24.51.253 local 172.24.51.254
Vl201 0 100 Standby 172.27.129.253 local 172.27.129.254

If I set set "Allowed vlan 40,41" on trunk port 0/15 and/or 0/16 of switch Switch1_A (and similarly vlan allowed 140,141 on trunk port 0/15 and/or 0/16 of switch1_B) sh standby brief command shows next crazy output:

#sh standby brief

Interface Grp Pri P State Active Standby Virtual IP
Vl40 0 255 P Active local 172.16.63.253 172.16.63.254
Vl41 0 255 P Active local 172.16.51.253 172.16.51.254
Vl101 0 255 P Active local unknown 172.27.65.254
Vl140 0 100 Active local unknown 172.24.63.254
Vl141 0 100 Active local unknown 172.24.51.254
Vl201 0 100 Active local unknown 172.27.129.254


I've to clarify that this doesn't happens if I remove "Allowed vlan 40,41" on trunk port 0/15 or 0/16 of switch1_A (or 140,141 from trunk of one port of 0/15 or 0/16 of switch1_B). We need them active on either 0/15 and 0/16.
Please help me. Wht is this happening?
Thank you a lot in advance.