è tanto che non scrivo sul forum, spero che tutti voi stiate bene!
Ho messo su un laboratorio virtuale con GNS3 med/grande e l'ho connesso al mio router.
Purtroppo non capisco il perchè propago la default route via BGP (default-information originate + net 0.0.0.0) e tutti gli AS la ricevono.
Il mio problema è se pur ricevendola , in tutti gli AS, facendo il traceroute arriva fino al mio router reale e poi si ferma

L'UNICO che riesce è l'access provider router (quello direttamente connesso all cloud ed è quello che comunica direttamente al router reale via BGP)
vi prendo la configurazione dell'ASBR (il router che fa load sharing in BGP che si trova sopra a ACCESS_PROVIDER)
========================================================
ASBR
========================================================
interface Loopback1
ip address 160.10.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 32.30.0.1 255.255.255.0
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 1 cisco
duplex auto
speed auto
!
interface Serial0/0
ip address 41.41.41.2 255.255.255.252
clockrate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 42.42.42.2 255.255.255.252
clockrate 2000000
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
auto-cost reference-bandwidth 1000
summary-address 50.50.0.0 255.255.252.0
network 32.30.0.1 0.0.0.0 area 0
!
router bgp 6500
no synchronization
bgp log-neighbor-changes
network 150.10.1.1
redistribute connected
neighbor 150.10.1.1 remote-as 1000
neighbor 150.10.1.1 ebgp-multihop 2
neighbor 150.10.1.1 update-source Loopback1
neighbor 150.10.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
no ip http secure-server
ip classless
ip route 50.50.0.0 255.255.255.0 Null0
ip route 50.50.1.0 255.255.255.0 Null0
ip route 50.50.2.0 255.255.255.0 Null0
ip route 50.50.3.0 255.255.255.0 Null0
ip route 150.10.1.0 255.255.255.0 42.42.42.1
ip route 150.10.1.0 255.255.255.0 41.41.41.1
!
----------------------------------------------------------------------------------------
ASBR#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
Known via "bgp 6500", distance 20, metric 0, candidate default path
Tag 1000, type external
Last update from 150.10.1.1 01:37:18 ago
Routing Descriptor Blocks:
* 150.10.1.1, from 150.10.1.1, 01:37:18 ago
Route metric is 0, traffic share count is 1
AS Hops 2
Route tag 1000
ASBR#sh ip bgp
BGP table version is 464, local router ID is 160.10.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 0.0.0.0 150.10.1.1 0 1000 12 i
ASBR#sh ip bgp 0.0.0.0
BGP routing table entry for 0.0.0.0/0, version 460
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Not advertised to any peer
1000 12, (received & used)
150.10.1.1 from 150.10.1.1 (150.10.1.1)
Origin IGP, localpref 100, valid, external, best
ASBR#traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1
1 42.42.42.1 16 msec
41.41.41.1 8 msec
42.42.42.1 8 msec
2 192.168.1.1 [AS 1000] 16 msec 8 msec 16 msec <<<<<<<<<<<< router di casa
3 *
========================================================
ACCESS_PROVIDER
========================================================
!
interface Loopback1
ip address 31.31.31.31 255.255.255.255
!
interface Loopback2
ip address 150.10.1.1 255.255.255.0
!
interface Loopback3
ip address 1.2.3.2 255.255.255.255
!
interface FastEthernet0/0
ip address 57.57.57.2 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto
!
interface Serial0/0
ip address 71.1.1.1 255.255.255.252
clockrate 2000000
!
interface FastEthernet0/1
description MYINTERNET
ip address 192.168.1.50 255.255.255.0
speed 10
full-duplex
!
interface Serial0/1
ip address 41.41.41.1 255.255.255.252
clockrate 2000000
!
interface Serial0/2
ip address 21.1.1.1 255.255.255.252
clockrate 2000000
!
interface Serial0/3
ip address 42.42.42.1 255.255.255.252
clockrate 2000000
!
interface Serial0/4
no ip address
shutdown
clockrate 2000000
!
interface Serial0/5
no ip address
shutdown
clockrate 2000000
!
!
router ospf 1
log-adjacency-changes
network 31.31.31.31 0.0.0.0 area 0
network 57.57.57.2 0.0.0.0 area 0
!
router bgp 1000
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor 1.2.3.1 remote-as 8500
neighbor 1.2.3.1 ebgp-multihop 2
neighbor 1.2.3.1 update-source Loopback3
neighbor 1.2.3.1 next-hop-self
neighbor 21.1.1.2 remote-as 4500
neighbor 21.1.1.2 next-hop-self
neighbor 32.32.32.32 remote-as 1000
neighbor 32.32.32.32 update-source Loopback1
neighbor 160.10.1.1 remote-as 6500
neighbor 160.10.1.1 ebgp-multihop 2
neighbor 160.10.1.1 update-source Loopback2
neighbor 160.10.1.1 next-hop-self
neighbor 160.10.1.1 soft-reconfiguration inbound
neighbor 192.168.1.1 remote-as 12
neighbor 192.168.1.1 soft-reconfiguration inbound
neighbor 192.168.1.1 prefix-list REALLAB out
no auto-summary
!
no ip http server
no ip http secure-server
ip classless
ip route 1.2.3.1 255.255.255.255 71.1.1.2
ip route 160.10.1.0 255.255.255.0 42.42.42.2
ip route 160.10.1.0 255.255.255.0 41.41.41.2
!
!
!
ip prefix-list REALLAB seq 10 permit 150.10.1.0/24
ip prefix-list REALLAB seq 20 permit 1.2.3.1/32
ip prefix-list REALLAB seq 30 permit 21.1.1.0/30
ip prefix-list REALLAB seq 40 permit 160.10.1.0/24
ip prefix-list REALLAB seq 50 permit 41.41.41.0/30
ip prefix-list REALLAB seq 60 permit 42.42.42.0/30
ip prefix-list REALLAB seq 70 deny 0.0.0.0/0 le 32
!
--------------------------------------------------------------------------------------
ACCESS_PROVIDER#sh ip bgp 0.0.0.0
BGP routing table entry for 0.0.0.0/0, version 399
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to update-groups:
1 3
12, (received & used)
192.168.1.1 from 192.168.1.1 (60.60.60.1)
Origin IGP, metric 0, localpref 100, valid, external, best
ACCESS_PROVIDER#tr
ACCESS_PROVIDER#traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1
1 192.168.1.1 12 msec
192.168.1.31 12 msec 8 msec
2 * * *
3 84.242.127.1 [AS 12] 256 msec 280 msec 240 msec
4 84.116.221.37 [AS 12] [MPLS: Label 314432 Exp 0] 272 msec 380 msec
ACCESS_PROVIDER#
========================================================
Router reale
========================================================
MI SONO FATTO AUTOGOAL xDD.
ho rivisto la configurazione del router di casa e come un pir e anche là mi sono scordato di nattare gli inidirizzi del lab
