Route-Map e Nat
Inviato: dom 20 gen , 2013 1:04 pm
Salve a tutti
vorrei raggiungere lo stesso server da 2 Isp diversi
faccio un esempio
Server Web 192.168.0.16 porta 8080
Penso di procedere cosi
route-map Test1 permit 10
match ip address 199
match interface FastEthernet1/0
set ip next-hop 10.0.2.1
exit
route-map Test2 permit 10
match ip address 199
match interface FastEthernet0/0
set ip next-hop 10.0.0.1
exit
ip nat inside source static tcp 192.168.0.16 8080 10.0.2.2 8080 route-map Test1 extendable
ip nat inside source static tcp 192.168.0.16 8080 10.0.0.2 8080 route-map Test2 extendable
access-list 199 permit tcp host 192.168.0.16 eq 8080 any
1° domanda .. approccio corretto ?
2° domanda (complico la faccenda)
considerando che sullo stesso router c'è questo load balance
ip nat inside source route-map WAN1 interface FastEthernet0/0 overload
ip nat inside source route-map WAN2 interface FastEthernet0/1 overload
route-map WAN1 permit 10
match ip address 100
match interface FastEthernet0/0
set ip next-hop 10.0.0.1
!
route-map WAN2 permit 10
match ip address 100
match interface FastEthernet0/1
set ip next-hop 10.0.1.1
nell' access list 100, a cui fanno riferimento queste 2 route map, inserisco questa entry ...
"access-list 100 deny tcp host 192.168.0.16 eq 8080 any"
in modo da sottrarre il traffico che mi interessa a queste 2 route map e lasciarlo alla nat statica che ho citato sopra
Strada Giusta ?
thanks !