Per prima cosa un salutone a tutto il forum. Premetto che e' la prima volta che mi capita di configurare un router cisco isdn.
Il mio problema e' questo:
ho un PC che a diversi orari deve effettuare chiamate isdn tramite router verso 3 numeri di telefono diversi per poter sincronizzare dei dati. L'autenticazione avviene tramite user e pwd e ad ogni collegamento debbo impostare un IP sul BR0 con route per raggiungere i pc remoti. Questi parametri per i 3 collegamenti sono tutti diversi. Ho provato con questa configurazione ma il router non l'accetta. Mi potete dare una mano? Grazie anticipatamente.
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$0v8I$yarzu/txxxxxxxxxxxxxxxx
!
username Router password 7 0xxxxxxxxxxxxxxxxxxx
no aaa new-model
ip subnet-zero
no ip source-route
!
isdn switch-type basic-net3
!
!
interface Ethernet0
ip address 10.1.24.163 255.255.248.0
ip access-group 121 in
no ip proxy-arp
ip nat inside
ip rip send version 1 2
ip rip receive version 1 2
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
dialer pool-member 2
dialer pool-member 3
isdn switch-type basic-net3
ppp authentication chap pap callin
!
interface Dialer1
description Server1
ip address 192.168.20.254 255.255.255.248
ip access-group 121 in
no ip proxy-arp
ip rip send version 1 2
ip rip receive version 1 2
encapsulation ppp
no ip split-horizon
dialer pool 1
dialer remote-name Cisco1
dialer idle-timeout 60
dialer string 0xxxxxxxxx class DialClass
dialer hold-queue 10
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname bdmgest
ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxx password 7 xxxxxxxxxxxxxxx
!
interface Dialer2
description Server2
ip address 10.20.30.2 255.255.255.252
ip access-group 121 in
no ip proxy-arp
ip rip send version 1 2
ip rip receive version 1 2
encapsulation ppp
no ip split-horizon
dialer pool 1
dialer remote-name Cisco2
dialer idle-timeout 60
dialer string 0xxxxxxxxxx class DialClass
dialer hold-queue 10
dialer-group 2
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxxxxx
ppp chap password 7 1xxxxxxxxxxxx3
ppp pap sent-username xxxxxxxxxx password 7 xxxxxxxxxxxxx
interface Dialer3
description Server3
ip address 172.16.251.63 255.255.0.0
ip access-group 121 in
no ip proxy-arp
ip rip send version 1 2
ip rip receive version 1 2
encapsulation ppp
no ip split-horizon
dialer pool 1
dialer remote-name Cisco3
dialer idle-timeout 60
dialer string 0xxxxxxxxx class DialClass
dialer hold-queue 10
dialer-group 3
ppp authentication chap pap callin
ppp chap hostname xxxxxxxxx
ppp chap password 7 xxxxxxxx
ppp pap sent-username xxxxxxxx password 7 xxxxxxx
!
router rip
passive-interface Dialer1
passive-interface Dialer2
passive-interface Dialer3
network 10.0.0.0
!
ip route 172.28.0.4 255.255.255.255 192.168.254.17 Dealer1
ip route 10.15.74.200 255.255.255.255 10.20.30.1 Dealer2
ip route 10.10.10.220 255.255.255.255 172.16.253.82 Dealer3
no ip http server
!
!
map-class dialer DialClass
access-list 18 permit 10.1.24.0 0.0.7.255
access-list 121 deny udp any eq netbios-dgm any
access-list 121 deny udp any eq netbios-ns any
access-list 121 deny udp any eq netbios-ss any
access-list 121 deny tcp any eq 137 any
access-list 121 deny tcp any eq 138 any
access-list 121 deny tcp any eq 139 any
access-list 121 permit ip any any time-range TIME
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
!
line con 0
exec-timeout 120 0
transport preferred all
transport output all
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
transport preferred all
transport input all
transport output all
!
no rcapi server
!
!
time-range TIME
periodic daily 0:00 to 23:59
!
!
end
Dove imposto il nat per le differenti chiamate?
A presto.
Configurazione CISCO 801
Moderatore: Federico.Lagni