Problema con Configurazione VRF sui CE

Tutto ciò che ha a che fare con la configurazione di apparati Cisco (e non rientra nelle altre categorie)

Moderators: Federico.Lagni, TheIrish, Wizard, tonycimo, andrewp

Problema con Configurazione VRF sui CE

Postby kobaiachi » Thu 11 Apr , 2019 11:58 pm

ciao a tutti è un bel po che non ci sentiamo...
dunque mi sto preparando per la CCIE ISP e piano piano che vado avanti con lo studio mi faccio dei laboratori (o copiati dagli esempi dei libri cisco o inventati di sana pianta)

ho un problema con la configurazione CE-PE-PE-CE in particolare quando il protocollo di routing tra il CE ed il PE è OSPF .
in particolare non vedo sul CE le rotte ospf redistribuite tramite BGP.

vi posto la mia configurazione.

CE 1
ip cef
!
!
ip vrf PLANET
rd 10:1
!
ip vrf VOIP
rd 20:1
!
!
!
interface Loopback0
ip vrf forwarding PLANET
ip address 172.16.0.1 255.255.255.255
!
!
interface Loopback1
ip vrf forwarding PLANET
ip address 172.16.0.2 255.255.255.255
!
!
interface Loopback2
ip vrf forwarding PLANET
ip address 172.16.0.3 255.255.255.255
!
!
interface Loopback3
description VRF VOIP
ip vrf forwarding VOIP
ip address 172.17.0.1 255.255.255.255
!
!
interface Loopback4
description VRF VOIP
ip vrf forwarding VOIP
ip address 172.17.0.2 255.255.255.255
!
!
interface Loopback10
ip vrf forwarding PLANET
ip address 192.168.10.10 255.255.255.255
!
!
interface Loopback20
ip vrf forwarding VOIP
ip address 172.17.10.10 255.255.255.255
!
!
interface Ethernet0/0
no ip address
shutdown
duplex auto
!
!
interface GigabitEthernet0/0
no ip address
duplex full
speed 1000
media-type gbic
negotiation auto
!
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip vrf forwarding PLANET
ip address 11.0.0.2 255.255.255.252
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip vrf forwarding VOIP
ip address 11.0.0.6 255.255.255.252
!
!
router ospf 3 vrf VOIP
router-id 172.17.10.10
log-adjacency-changes
network 11.0.0.4 0.0.0.3 area 0
network 172.17.0.0 0.0.0.255 area 0
network 172.17.10.0 0.0.0.255 area 0
!
router ospf 2 vrf PLANET
router-id 192.168.10.10
log-adjacency-changes
network 11.0.0.0 0.0.0.3 area 0
network 172.16.0.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!

PE-1
ip cef
!
!
ip vrf PLANET
rd 10:1
route-target export 10:1
route-target import 10:1
!
ip vrf VOIP
rd 20:1
route-target export 20:1
route-target import 20:1
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng reoptimize events link-up
interface Loopback0
ip address 192.168.1.1 255.255.255.255
!
!
interface Loopback10
ip vrf forwarding PLANET
ip address 192.168.10.1 255.255.255.255
!
!
interface Loopback20
ip vrf forwarding VOIP
ip address 172.17.10.1 255.255.255.255
!
!
interface Ethernet0/0
no ip address
shutdown
duplex auto
!
!
interface GigabitEthernet0/0
no ip address
duplex full
speed 1000
media-type gbic
negotiation auto
!
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip vrf forwarding PLANET
ip address 11.0.0.1 255.255.255.252
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip vrf forwarding VOIP
ip address 11.0.0.5 255.255.255.252
!
interface GigabitEthernet1/0
bandwidth 100000
ip address 10.0.0.1 255.255.255.252
ip ospf network point-to-point
negotiation auto
mpls ip
!

router ospf 2 vrf PLANET
router-id 192.168.10.1
log-adjacency-changes
redistribute bgp 1 metric 10 subnets
network 11.0.0.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 0
!
router ospf 3 vrf VOIP
router-id 172.17.10.1
log-adjacency-changes
redistribute bgp 1 metric 10 subnets
network 11.0.0.4 0.0.0.3 area 0
network 172.17.10.0 0.0.0.255 area 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.0.0.255 area 0
!
router bgp 1
bgp router-id 192.168.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.6.6 remote-as 1
neighbor 192.168.6.6 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 192.168.6.6 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 192.168.6.6 activate
neighbor 192.168.6.6 send-community extended
exit-address-family
!
address-family ipv4 vrf PLANET
no synchronization
redistribute connected
redistribute static
redistribute ospf 2 vrf PLANET metric 10 match internal external 1 external 2
exit-address-family
!
address-family ipv4 vrf VOIP
no synchronization
redistribute connected
redistribute static
redistribute ospf 3 vrf VOIP metric 10 match internal external 1 external 2
exit-address-family
!
le configurazioni del Pe2 e del CE2 e esattamente speculare.
sul CE2 pero non vedo le rotte OSPF che dovrebbero appartenere al CE1 anche se sono presenti nel database OSPF.
CE2#show ip ospf 2 database

OSPF Router with ID (192.168.10.11) (Process ID 2)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
192.168.10.6 192.168.10.6 398 0x80000002 0x000393 2
192.168.10.11 192.168.10.11 397 0x80000002 0x00AD65 5

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
12.0.0.2 192.168.10.11 397 0x80000001 0x00A216

Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
11.0.0.0 192.168.10.6 373 0x80000001 0x004EE2
172.16.0.1 192.168.10.6 373 0x80000001 0x00601B
172.16.0.2 192.168.10.6 373 0x80000001 0x005624
172.16.0.3 192.168.10.6 373 0x80000001 0x004C2D
192.168.10.1 192.168.10.6 373 0x80000001 0x00C5FE
192.168.10.10 192.168.10.6 373 0x80000001 0x006B50


Show ip route VRF PLANET
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.0.0.0/30 is directly connected, GigabitEthernet0/0.10
L 12.0.0.2/32 is directly connected, GigabitEthernet0/0.10
172.16.0.0/32 is subnetted, 3 subnets
C 172.16.2.1 is directly connected, Loopback0
C 172.16.2.2 is directly connected, Loopback1
C 172.16.2.3 is directly connected, Loopback2
192.168.10.0/32 is subnetted, 2 subnets
O 192.168.10.6 [110/2] via 12.0.0.1, 00:07:30, GigabitEthernet0/0.10
C 192.168.10.11 is directly connected, Loopback10

avete qualche suggerimento ?
kobaiachi
Cisco pathologically enlightened user
 
Posts: 175
Joined: Thu 27 Oct , 2005 3:34 pm

Re: Problema con Configurazione VRF sui CE

Postby kobaiachi » Fri 12 Apr , 2019 12:29 am

se invece di dare su CE1 le reti con il comado network 172.16.0.0 0.0.0.255 area 0 do il comando redistribute connected vedo le rotte nella tabella di routing su CE2 come E2 external 2 .
lo so che deve essere qualcosa che mi sfugge ma non riesco a capire cosa
kobaiachi
Cisco pathologically enlightened user
 
Posts: 175
Joined: Thu 27 Oct , 2005 3:34 pm


Return to Configurazioni

Who is online

Users browsing this forum: No registered users and 4 guests

cron