vDSL di TelecomItalia con router Cisco

Configurazioni per connettività ADSL, ISDN e switch per privati e piccole network

Moderators: Federico.Lagni, TheIrish, Wizard, andrewp

vDSL di TelecomItalia con router Cisco

Postby Frisco » Thu 11 Dec , 2014 9:53 am

Buongiorno a tutti,
mi hanno recentemente migrato la connettiviya` da ADSL a vDSL FTTC.
Purtoppo, essendo la fonia VoIP, mi e` stato consegnato un modem/router Technicolor che devo usare per la connessione e la fonia.
Questo mi seri problemi, soprattutto di raggiungibilita` dall'esterno dei servizi e backup UMTS precedentemente forniti dal mio Cisco 2911 con EHWIC-VA-DSL-A.
Ho creato quindi la seguente config che riporto per le parti essenziali vDSL:

controller VDSL 0/0/0
description vDSL Telecom
!
interface Ethernet0/0/0
no ip address
!
interface Ethernet0/0/0.835
encapsulation dot1Q 835
ip nat inside
ip virtual-reassembly in
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Ethernet0/0/0.837
encapsulation dot1Q 837
pppoe enable group global
pppoe-client dial-pool-number 10
!
interface Dialer0
ip address negotiated
no ip unreachables
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
ppp authentication pap chap callin
ppp chap hostname aliceadls
ppp chap password aliceadls
no ppp chap wait
ppp pap sent-username aliceadls password aliceadsl
ppp ipcp dns request
ppp ipcp address accept
!

interface Dialer10
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 10
dialer idle-timeout 5
dialer-group 10
ppp authentication pap callin
ppp pap sent-username telegestione password telegestione
ppp ipcp dns request accept
ppp ipcp address accept
no cdp enable
!

Connettendo il doppino alla scheda, il controller vdsl 0/0/0 si allinea, i dialer ottengono due IP diversi e si puo` uscire all'esterno ma, ahime`, il controller si disallinea dopo circa 30 secondi. Aspettando ancora un po il controller si riallinea, dopo 30 secondi si disallinea e cosi` via all'infinito.
Ho anche notato che nessuno dei due IP asseganti ai due Dialer e` uguale a quello (statico) assegnato al modem Tecnicolor.

Qualcuno puo` darmi una mano a riguardo?

Grazie anticipatamente.
Frisco
Cisco power user
 
Posts: 86
Joined: Thu 29 Jan , 2009 3:42 pm

Re: vDSL di TelecomItalia con router Cisco

Postby Frisco » Sun 14 Dec , 2014 10:51 am

Nessuno che sia stato piu` fortunato di me con la vDSL di TI e Cisco?
Frisco
Cisco power user
 
Posts: 86
Joined: Thu 29 Jan , 2009 3:42 pm

Re: vDSL di TelecomItalia con router Cisco

Postby lorbellu » Fri 24 Jul , 2015 10:48 pm

Ciao,

girando un po' sul forum mi sono imbattuto in questo tuo vecchio post, ho visto che hai risolto su un altro post, posto la risposta a beneficio di altri che potrebbero avere lo stesso problema.
Il problema da te lamentato sta nella versione firmware del modem VDSL caricato sulla EHWIC-VS-DSL-A.
Come riporta la tabella a questo link, il firmware della tua versione deve essere A2pv6C033c.d23e per essere compatibile con la VDSL2 di Telecom Italia.
Il problema nasce dal supporto al vectoring, implementato con il VDSL2 per la riduzione del crosstalk sui doppini in rame. In pratica, le versioni di firmware antecedenti a quella indicata, non supportano il vectoring e quindi il modem funziona solo in ADSL2 o VDSL rendendo saltellante la linea.

Saluti
Lorbellu
Lorbellu
lorbellu
Network Emperor
 
Posts: 313
Joined: Thu 25 Oct , 2007 6:14 pm

Re: vDSL di TelecomItalia con router Cisco

Postby mmarangon61 » Sun 20 Nov , 2016 4:25 pm

Ehmmm... un certo imbarazzo... Non ho rinnovato il TAC di Cisco :-( Qualcuno per favore mi può regalare, o posso anche pagare su postepay, il firmware A2pv6C033c.d23e ?

Ho un 887VA e telecom italia...

Oppure regalo Panettone a Natale... Su... su... per favore... :oops:
mmarangon61
Cisco fan
 
Posts: 34
Joined: Sun 28 Oct , 2007 1:21 am

Re: vDSL di TelecomItalia con router Cisco

Postby mmarangon61 » Tue 22 Nov , 2016 7:51 pm

Frisco wrote:Buongiorno a tutti,
mi hanno recentemente migrato la connettiviya` da ADSL a vDSL FTTC.
Purtoppo, essendo la fonia VoIP, mi e` stato consegnato un modem/router Technicolor che devo usare per la connessione e la fonia.
Questo mi seri problemi, soprattutto di raggiungibilita` dall'esterno dei servizi e backup UMTS precedentemente forniti dal mio Cisco 2911 con EHWIC-VA-DSL-A.
Ho creato quindi la seguente config che riporto per le parti essenziali vDSL:

controller VDSL 0/0/0
description vDSL Telecom
!
interface Ethernet0/0/0
no ip address
!
interface Ethernet0/0/0.835
encapsulation dot1Q 835
ip nat inside
ip virtual-reassembly in
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Ethernet0/0/0.837
encapsulation dot1Q 837
pppoe enable group global
pppoe-client dial-pool-number 10
!
interface Dialer0
ip address negotiated
no ip unreachables
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
ppp authentication pap chap callin
ppp chap hostname aliceadls
ppp chap password aliceadls
no ppp chap wait
ppp pap sent-username aliceadls password aliceadsl
ppp ipcp dns request
ppp ipcp address accept
!

interface Dialer10
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 10
dialer idle-timeout 5
dialer-group 10
ppp authentication pap callin
ppp pap sent-username telegestione password telegestione
ppp ipcp dns request accept
ppp ipcp address accept
no cdp enable
!

Connettendo il doppino alla scheda, il controller vdsl 0/0/0 si allinea, i dialer ottengono due IP diversi e si puo` uscire all'esterno ma, ahime`, il controller si disallinea dopo circa 30 secondi. Aspettando ancora un po il controller si riallinea, dopo 30 secondi si disallinea e cosi` via all'infinito.
Ho anche notato che nessuno dei due IP asseganti ai due Dialer e` uguale a quello (statico) assegnato al modem Tecnicolor.

Qualcuno puo` darmi una mano a riguardo?

Grazie anticipatamente.

Questa configurazione, sulla quale ho mille dubbi, non va una pippa. Ho un 887VA e fibra ottica 100/20 con Telecom.
Un aiutino per favore?
Se ho capito bene non c'è scambio dati/autenticazione/IP pubblico
!
!
!
no ip routing
!
!
!
--More--
*Nov 22 18:25:58.235: %ENVMON-3-FAN_FAILED: Fan is malfu g
Router#sh config
Using 1928 out of 262136 bytes
!
! Last configuration change at 22:56:11 UTC Mon Nov 21 2016
!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
memory-size iomem 10
!
!
!
!
!
!
!
no ip routing
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
vpdn enable
!
vpdn-group 1
!

!
!
!
!
!
!
!
controller VDSL 0
operating mode auto vdsl2
sra
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0
no ip address
no ip route-cache
shutdown
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Ethernet0.835
encapsulation dot1Q 835
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
no ip route-cache
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
switchport access vlan 100
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan100
ip address 192.168.1.5 255.255.255.0
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap password 0 aliceadsl
ppp pap sent-username aliceadsl password 0 aliceadsl
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
!
dialer-list 1 protocol ip permit
!
access-list 1 permit any
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
!
line con 0
no modem enable
speed 115200
line aux 0
line vty 0 4
login
transport input none
!
!
end

Router#
Router#
Router#

mmarangon61
Cisco fan
 
Posts: 34
Joined: Sun 28 Oct , 2007 1:21 am

Re: vDSL di TelecomItalia con router Cisco

Postby lazzaronetu » Tue 22 Nov , 2016 8:39 pm

interface Ethernet0
no ip address
no ip route-cache
shutdown
pppoe enable group global
pppoe-client dial-pool-number 1


metti cosi:

interface Ethernet0
no ip address
!
interface Ethernet0.835
encapsulation dot1Q 835
pppoe enable group global
pppoe-client dial-pool-number 1

ppp authentication chap callin
ppp chap password 0 aliceadsl
ppp pap sent-username aliceadsl password 0 aliceadsl


l'username chap ???????

metti cosi:

ppp authentication pap chap callin
ppp chap hostname [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed
ppp chap password 0 alicenewag
ppp pap sent-username [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed password 0 alicenewag

se hai una business e vuoi l'ip statico, altrimenti con aliceadsl come user/pass ottieni la connessione ugualmente ma con ip dinamico!!!
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Cisco Router 887VA-W
IOS Release : c800-universalk9-mz.SPA.156-2.T
xDSL Firmware: VA_A_39d_B_38h3_24h_1
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
User avatar
lazzaronetu
Cisco fan
 
Posts: 45
Joined: Thu 25 Feb , 2010 3:52 pm

Re: vDSL di TelecomItalia con router Cisco

Postby mmarangon61 » Sat 26 Nov , 2016 2:04 pm

lorbellu wrote:Ciao,

girando un po' sul forum mi sono imbattuto in questo tuo vecchio post, ho visto che hai risolto su un altro post, posto la risposta a beneficio di altri che potrebbero avere lo stesso problema.
Il problema da te lamentato sta nella versione firmware del modem VDSL caricato sulla EHWIC-VS-DSL-A.
Come riporta la tabella a questo link, il firmware della tua versione deve essere A2pv6C033c.d23e per essere compatibile con la VDSL2 di Telecom Italia.
Il problema nasce dal supporto al vectoring, implementato con il VDSL2 per la riduzione del crosstalk sui doppini in rame. In pratica, le versioni di firmware antecedenti a quella indicata, non supportano il vectoring e quindi il modem funziona solo in ADSL2 o VDSL rendendo saltellante la linea.

Saluti
Lorbellu

Per favore Lorbellu potresti rimettere in linea in firmware che suggerisci per telecom italia? Domani attivo un abbonamento Cisco ma ora sono a piedi. E' introvabile.
mmarangon61
Cisco fan
 
Posts: 34
Joined: Sun 28 Oct , 2007 1:21 am

Re: vDSL di TelecomItalia con router Cisco

Postby Neutrino » Sun 27 Nov , 2016 10:17 pm

lazzaronetu wrote:interface Ethernet0
no ip address
no ip route-cache
shutdown
pppoe enable group global
pppoe-client dial-pool-number 1


metti cosi:

interface Ethernet0
no ip address
!
interface Ethernet0.835
encapsulation dot1Q 835
pppoe enable group global
pppoe-client dial-pool-number 1

ppp authentication chap callin
ppp chap password 0 aliceadsl
ppp pap sent-username aliceadsl password 0 aliceadsl


l'username chap ???????

metti cosi:

ppp authentication pap chap callin
ppp chap hostname [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed
ppp chap password 0 alicenewag
ppp pap sent-username [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed password 0 alicenewag

se hai una business e vuoi l'ip statico, altrimenti con aliceadsl come user/pass ottieni la connessione ugualmente ma con ip dinamico!!!


Ciao Lazzaronetu, la settimana scorsa la Telecom finalmente (richiesta fatta a giugno) mi ha attivato la connessione in fibra Vdsl 100/20. Ho un router Cisco 1941 con controller Cisco EHWIC-VA-DSL-M. Il firmware del controller è 130205_1433-4.02L.03.A2pv6C035j.d23j. Ho provato a configurare Dialer0 secondo quanto esposto su ma evidentemente c'è qualcosa che non ho capito. Il modem non si allinea. Devo usare il Dialer oppure no? Questa la mia configurazione

interface GigabitEthernet0/0
description $ETH-LAN$
ip address 192.168.1.1 255.255.255.0
ip directed-broadcast 103
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no cdp enable
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Ethernet0/0/0
no ip address
shutdown
!
interface Cellular0/1/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 2
async mode interactive
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed
ppp chap password 0 alicenewag
ppp pap sent-username [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed password 0 alicenewag
no cdp enable


Grazie in anticipo per l'aiuto
Neutrino
n00b
 
Posts: 8
Joined: Mon 09 Feb , 2015 3:01 pm

Re: vDSL di TelecomItalia con router Cisco

Postby lazzaronetu » Sun 27 Nov , 2016 10:55 pm

Ti hanno dato i dati della punto-punto oppure installato il loro modem e basta?

Devi disattivare l'interfaccia atm e utilizzare la ethernet creando la ethernet0.835, guarda la conf sopra!

Aggiorna Ios e vdsl firmware se ti è possibile!
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Cisco Router 887VA-W
IOS Release : c800-universalk9-mz.SPA.156-2.T
xDSL Firmware: VA_A_39d_B_38h3_24h_1
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
User avatar
lazzaronetu
Cisco fan
 
Posts: 45
Joined: Thu 25 Feb , 2010 3:52 pm

Re: vDSL di TelecomItalia con router Cisco

Postby Neutrino » Mon 28 Nov , 2016 10:45 am

Mi hanno solo installato il modem. Per quanto riguarda i dati pare che siano coperti da segreto di stato Telecom=CIA. Disattivo la ATM e faccio la ethernet0.835, che in realtà avevo già fatto ma per errore ho postato la conf vecchia, e ti faccio sapere. Relativamente all'aggiornamento firmware dell'ios e della VDSL, non posso scaricarli dal sito pubblico di cisco? Devo avere una sorta di contratto a pagamento? Grazie ancora
Neutrino
n00b
 
Posts: 8
Joined: Mon 09 Feb , 2015 3:01 pm

Re: vDSL di TelecomItalia con router Cisco

Postby lazzaronetu » Mon 28 Nov , 2016 2:45 pm

Neutrino wrote:Mi hanno solo installato il modem. Per quanto riguarda i dati pare che siano coperti da segreto di stato Telecom=CIA. Disattivo la ATM e faccio la ethernet0.835, che in realtà avevo già fatto ma per errore ho postato la conf vecchia, e ti faccio sapere. Relativamente all'aggiornamento firmware dell'ios e della VDSL, non posso scaricarli dal sito pubblico di cisco? Devo avere una sorta di contratto a pagamento? Grazie ancora


Per quanto riguarda la connessione dati le user e password ho spiegato sopra come inserirle per ottenere l'IP statico.

Per quanto riguarda la Fonia ho indicato nell'altro mio post come estrapolarli oppure vai qui http://www.hwupgrade.it/forum/showpost. ... count=3330

Per l'aggiornamento ios e fw ti mando un PM
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Cisco Router 887VA-W
IOS Release : c800-universalk9-mz.SPA.156-2.T
xDSL Firmware: VA_A_39d_B_38h3_24h_1
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
User avatar
lazzaronetu
Cisco fan
 
Posts: 45
Joined: Thu 25 Feb , 2010 3:52 pm

Re: vDSL di TelecomItalia con router Cisco

Postby Neutrino » Mon 28 Nov , 2016 7:34 pm

Buonasera, dopo aver disattivato la Atm e fatto qualche altra modifica, finalmente il modem si allinea. Riesco a pingare verso l'esterno e risolvo anche i nomi. Però stranamente succede che se faccio una ricerca in google, mi compaiono i risultati ma quando clicco su uno di essi, non riesco ad arrivare alla pagina di destinazione. Inizialmente pensavo fosse un problema di dns, ma da un pc interno alla rete, se faccio il ping a google.it il nome viene risolto. Ho notato però che non tutti i nomi vengono risolti. E' un problema di routing? Di seguito la configurazione.

version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXX
!
boot-start-marker
boot-end-marker
!
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
!
!
!
!
controller Cellular 0/1
!
controller VDSL 0/0/0
operating mode vdsl2
!
track 234 ip sla 1 reachability
!
!
!
!
!
interface Loopback0
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
no cdp enable
!
interface GigabitEthernet0/0
description $ETH-LAN$
ip address 192.168.1.1 255.255.255.0
ip directed-broadcast 103
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no cdp enable
!
interface ATM0/0/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
shutdown
!
interface Ethernet0/0/0
no ip address
!
interface Ethernet0/0/0.835
encapsulation dot1Q 835
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Cellular0/1/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 2
async mode interactive
!
interface Virtual-Template1 type tunnel
ip unnumbered Loopback0
tunnel mode ipsec ipv4
tunnel protection ipsec profile CiscoCP_Profile1
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed
ppp chap password 0 alicenewag
ppp pap sent-username [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed password 0 alicenewag
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip local policy route-map track-primary-if
ip local pool SDM_POOL_1 192.168.2.20 192.168.2.40
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip dns server
ip nat inside source route-map nat2cell interface Cellular0/1/0 overload
ip nat inside source route-map nat2dsl interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 254
!
ip sla auto discovery
ip sla 1
icmp-echo x.x.x.x source-interface Dialer0
threshold 500
timeout 1000
frequency 3
ip sla schedule 1 life forever start-time now
no service-routing capabilities-manager
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
no cdp run
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer0 Null0
!
route-map nat2dsl permit 10
match ip address 101
match interface Dialer0
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0/1/0
!
!
access-list 100 remark CCP_ACL Category=4
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 101 remark CCP_ACL Category=18
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 remark CCP_ACL Category=16
access-list 102 permit icmp any host x.x.x.x
access-list 103 permit udp host 192.168.2.0 any
access-list 104 remark CCP_ACL Category=4
access-list 104 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/1/0
script dialer lte
modem InOut
no exec
line vty 0 4
password xxxxxxx
transport input all
!
scheduler allocate 20000 1000
event manager applet pri_back
event track 234 state any
action 2.0 cli command "clear ip nat trans forced"
!
end
Neutrino
n00b
 
Posts: 8
Joined: Mon 09 Feb , 2015 3:01 pm

Re: vDSL di TelecomItalia con router Cisco

Postby lazzaronetu » Tue 29 Nov , 2016 6:38 pm

Neutrino wrote:Buonasera, dopo aver disattivato la Atm e fatto qualche altra modifica, finalmente il modem si allinea. Riesco a pingare verso l'esterno e risolvo anche i nomi. Però stranamente succede che se faccio una ricerca in google, mi compaiono i risultati ma quando clicco su uno di essi, non riesco ad arrivare alla pagina di destinazione. Inizialmente pensavo fosse un problema di dns, ma da un pc interno alla rete, se faccio il ping a google.it il nome viene risolto. Ho notato però che non tutti i nomi vengono risolti. E' un problema di routing? Di seguito la configurazione.

version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXX
!
boot-start-marker
boot-end-marker
!
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
!
!
!
!
controller Cellular 0/1
!
controller VDSL 0/0/0
operating mode vdsl2
!
track 234 ip sla 1 reachability
!
!
!
!
!
interface Loopback0
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
no cdp enable
!
interface GigabitEthernet0/0
description $ETH-LAN$
ip address 192.168.1.1 255.255.255.0
ip directed-broadcast 103
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no cdp enable
!
interface ATM0/0/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
shutdown
!
interface Ethernet0/0/0
no ip address
!
interface Ethernet0/0/0.835
encapsulation dot1Q 835
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Cellular0/1/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 2
async mode interactive
!
interface Virtual-Template1 type tunnel
ip unnumbered Loopback0
tunnel mode ipsec ipv4
tunnel protection ipsec profile CiscoCP_Profile1
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed
ppp chap password 0 alicenewag
ppp pap sent-username [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed password 0 alicenewag
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip local policy route-map track-primary-if
ip local pool SDM_POOL_1 192.168.2.20 192.168.2.40
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip dns server
ip nat inside source route-map nat2cell interface Cellular0/1/0 overload
ip nat inside source route-map nat2dsl interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 254
!
ip sla auto discovery
ip sla 1
icmp-echo x.x.x.x source-interface Dialer0
threshold 500
timeout 1000
frequency 3
ip sla schedule 1 life forever start-time now
no service-routing capabilities-manager
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
no cdp run
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer0 Null0
!
route-map nat2dsl permit 10
match ip address 101
match interface Dialer0
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0/1/0
!
!
access-list 100 remark CCP_ACL Category=4
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 101 remark CCP_ACL Category=18
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 remark CCP_ACL Category=16
access-list 102 permit icmp any host x.x.x.x
access-list 103 permit udp host 192.168.2.0 any
access-list 104 remark CCP_ACL Category=4
access-list 104 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/1/0
script dialer lte
modem InOut
no exec
line vty 0 4
password xxxxxxx
transport input all
!
scheduler allocate 20000 1000
event manager applet pri_back
event track 234 state any
action 2.0 cli command "clear ip nat trans forced"
!
end
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Cisco Router 887VA-W
IOS Release : c800-universalk9-mz.SPA.156-2.T
xDSL Firmware: VA_A_39d_B_38h3_24h_1
-- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
User avatar
lazzaronetu
Cisco fan
 
Posts: 45
Joined: Thu 25 Feb , 2010 3:52 pm

Re: vDSL di TelecomItalia con router Cisco

Postby Neutrino » Wed 30 Nov , 2016 1:51 pm

Buongiorno, ho aggiornato il firmware della EHWIC-VDSL, ho fatto le modifiche suggerite, ma nulla da fare. Se eseguo un ping ad un nome a dominio direttamente dal router funziona bene e sempre, cioè risolve qualsiasi nome. Mi sono connesso al router tramite seriale e ho visto che a volte la connessione vdsl cade e sale la cellular, ma non sempre (non sono sicuro se si tratta di pura casualità, non vorrei dare informazioni errate). Tramite IP SLA, faccio un ping sulla connessione vdsl, in caso questo non va a buon fine, sale la cellular. Non vorrei che il router non riesce più ad effettuare questo controllo e per questo motivo fa salire la connessione di backup. Non riesco a capire dove è l'errore! Di seguito la configurazione completa.

version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xxxxx
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
no process cpu extended history
no process cpu autoprofile hog
!
!
!
!
!
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
!
redundancy
!
!
!
!
!
controller Cellular 0/1
!
controller VDSL 0/0/0
operating mode vdsl2
!
track 234 ip sla 1 reachability
!
no ip ftp passive
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.255
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
no cdp enable
!
interface GigabitEthernet0/0
description $ETH-LAN$
ip address 192.168.1.1 255.255.255.0
ip directed-broadcast 103
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
no cdp enable
!
interface ATM0/0/0
no ip address
shutdown
no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
shutdown
!
interface Ethernet0/0/0
no ip address
!
interface Ethernet0/0/0.835
encapsulation dot1Q 835
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Cellular0/1/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 2
async mode interactive
!
interface Virtual-Template1 type tunnel
ip unnumbered Loopback0
tunnel mode ipsec ipv4
tunnel protection ipsec profile CiscoCP_Profile1
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed
ppp chap password 0 alicenewag
ppp pap sent-username [SERIALMODEMTECHINICOLOR-MACADDR_PRIMI_6_CARATTERI]@alicebiz.routed password 0 alicenewag
ppp ipcp dns request accept
no cdp enable
!
ip local policy route-map track-primary-if
ip local pool SDM_POOL_1 192.168.2.20 192.168.2.40
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
!
ip dns server
ip nat inside source route-map nat2cell interface Cellular0/1/0 overload
ip nat inside source route-map nat2dsl interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0 track 234
!
ip sla auto discovery
ip sla 1
icmp-echo [MIO_IP_STATICO] source-interface Dialer0
threshold 500
timeout 1000
frequency 3
ip sla schedule 1 life forever start-time now
no service-routing capabilities-manager
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
no cdp run
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer0 Null0
!
route-map nat2dsl permit 10
match ip address 101
match interface Dialer0
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0/1/0
!
!
access-list 100 remark CCP_ACL Category=4
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 101 remark CCP_ACL Category=18
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 remark CCP_ACL Category=16
access-list 102 permit icmp any host 79.7.218.221
access-list 103 permit udp host 192.168.2.0 any
access-list 104 remark CCP_ACL Category=4
access-list 104 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/1/0
script dialer lte
modem InOut
no exec
line vty 0 4
password XXXXX
transport input all
!
scheduler allocate 20000 1000
event manager applet pri_back
event track 234 state any
action 2.0 cli command "clear ip nat trans forced"
!
end
Neutrino
n00b
 
Posts: 8
Joined: Mon 09 Feb , 2015 3:01 pm

Re: vDSL di TelecomItalia con router Cisco

Postby Neutrino » Tue 06 Dec , 2016 8:23 pm

RISOLTO!!!
Visto che nel Dialer0 è specificata una mtu 1492, nella Gigabit interna bisognava aggiungere ip tcp adjust-mss 1452, come indicato da lazzaronetu in un altro post.
Grazie lazzoronetu!
PS. Resta ancora un altro problema: i parametri Voip, ho provato ad estrapolarli secondo la guida, ma credo che quei gran signori della telecom abbiano aggiornato l'app, per cui, se rileva che vi è un proxy, non riceve il provisioning. Spero tanto di sbagliarmi, ma credo che sia così. C'è un altra strada?
Neutrino
n00b
 
Posts: 8
Joined: Mon 09 Feb , 2015 3:01 pm

Next

Return to Configurazioni End User

Who is online

Users browsing this forum: No registered users and 2 guests