Save The Date: 6 Novembre 2014
Oggi è gio 24 apr , 2014 3:28 pm

Tutti gli orari sono UTC + 1 ora




Apri un nuovo argomento Rispondi all’argomento  [ 9 messaggi ] 
Autore Messaggio
 Oggetto del messaggio: configurare cisco 1841 con 2 wic adsl + NAT
MessaggioInviato: dom 26 dic , 2010 9:05 am 
Non connesso
Cisco pathologically enlightened user
Avatar utente

Iscritto il: lun 18 ott , 2010 11:05 am
Messaggi: 216
Ciao a tutti,

come da titolo, ho un cisco 1841 con 2 wic adsl.

ho bisogno di configurare i due wic in modo da ottenere connessione adsl (ogni wic è collegato ad una linea differente)

ed ovviamente aggiungere il nat.

questo mi serve per avere un minimo di ridondanza.

Se una linea fallisce, vorrei che ci fosse la seconda a restare attiva.

tutto ok quando configuro la prima linea adsl su ATM0/0/0 con NAT overload.

la fa0/0 va sulla mia LAN, quindi con nat inside.

quando provo a configurare la seconda linead adsl su ATM0/1/0, non ottengo nessuna connessione...

avrei anche bisogno di un aiuto con la configurazione del NAT, visto che nat overload sembra lo possa applicare su una sola interfaccia.

questa è la mia configurazione:

Codice:
sis-router2#show run
Building configuration...

Current configuration : 3188 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname sis-router2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$o51Q$MotePLBmQQmLRQOZ6fHXO0
!
no aaa new-model
ip cef
!
!
!
!
ip domain name sislocal
multilink bundle-name authenticated
vpdn enable
!
vpdn-group pppoe
request-dialin
  protocol pppoe
l2tp tunnel receive-window 1024
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface FastEthernet0/0
description Interface connected to RED interface on ENDIAN
ip address 192.168.1.11 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
glbp 1 ip 192.168.1.1
!
interface FastEthernet0/1
description Interface for QSI severs lisead lines
ip address 192.168.0.99 255.255.255.0
duplex auto
speed auto
!
interface ATM0/0/0
description Phone line number XXXXXX
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 8/35
  pppoe-client dial-pool-number 1
!
!
interface ATM0/1/0
description Phone line number XXXXXX
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 8/35
  pppoe-client dial-pool-number 2
!
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname SISADSL2
ppp chap password 7 XXXXXXXXXXXXX
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 2
ppp authentication chap callin
ppp chap hostname SISADSLI
ppp chap password 7 XXXXXXXXXXX
!
router rip
network 192.168.0.0
network 192.168.1.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route XXX.XXX.XXX.XXX 255.255.255.240 192.168.0.1
ip route XXX.XXX.XXX.XXX 255.255.255.248 192.168.0.1
ip route XXX.XXX.XXX.XXX 255.255.255.248 192.168.0.1
ip route XXX.XXX.XXX.XXX 255.255.255.192 192.168.0.1
!
!
ip http server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
control-plane
!
banner motd ^C
                            _
      .::::::::::.        -(_)====u         .::::::::::.
    .::::''''''::::.                      .::::''''''::::.
  .:::'          `::::....          ....::::'          `:::.
.::'             `:::::::|        |:::::::'             `::.
.::|               |::::::|_ ___ __|::::::|               |::.
`--'               |::::::|_()__()_|::::::|               `--'
:::               |::-o::|        |::o-::|               :::
`::.             .|::::::|        |::::::|.             .::'
  `:::.          .::\-----'        `-----/::.          .:::'
    `::::......::::'                      `::::......::::'
      `::::::::::'                          `::::::::::'

    This is the Sanaa International School router
    You are supposed to be here only if Authorized,
    if you are not, please go away, all not authorized
    accesses are logged and will be pursued by law.
^C
!
line con 0
password 7 XXXXXXXXXXXX
login
line aux 0
line vty 0 4
password 7 XXXXXXXXXXXX
login
line vty 5 30
password 7 XXXXXXXXXXXX
login
!
scheduler allocate 20000 1000
end


Come potete vedere, solo la prima interfaccia si connette... e non mi è chiaro il motivo, dato che la configurazione delle interfaccie è identica, usando ovviamente due "pool" diversi

Codice:
sis-router2#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.11    YES NVRAM  up                    up     
FastEthernet0/1            192.168.0.99    YES NVRAM  up                    up     
ATM0/0/0                   unassigned      YES NVRAM  up                    up     
ATM0/1/0                   unassigned      YES manual up                    up     
NVI0                       192.168.1.11    YES unset  up                    up     
Virtual-Access1            unassigned      YES unset  up                    up     
Dialer0                    XX.XXX.XX.XX    YES IPCP   up                    up     
Dialer1                    unassigned      YES manual up                    up


Top
 Profilo  
 
 Oggetto del messaggio:
MessaggioInviato: dom 26 dic , 2010 3:41 pm 
Non connesso
Cisco pathologically enlightened user
Avatar utente

Iscritto il: lun 18 ott , 2010 11:05 am
Messaggi: 216
per la mancata connessione all'adsl su atm0/1/0 sembra che sia colpa del wic! l'ho sostituito ed è andato tutto ok..

adesso.. come dovrei configurare il NAT ? non sono sicuro..

grazie per l'aiuto


Top
 Profilo  
 
 Oggetto del messaggio:
MessaggioInviato: dom 26 dic , 2010 4:43 pm 
Non connesso
Network Emperor
Avatar utente

Iscritto il: gio 31 lug , 2008 4:55 pm
Messaggi: 252
Località: Battipaglia (SA)
Credo che basti una route map , dai anche un'occhiata al track delle route .

_________________
CCNA 640-802
CCNP SWITCH 642-813


Top
 Profilo  
 
 Oggetto del messaggio:
MessaggioInviato: dom 26 dic , 2010 8:12 pm 
Non connesso
Messianic Network master

Iscritto il: ven 29 gen , 2010 10:25 am
Messaggi: 2054
Località: Prov di GE
rain3 ha scritto:
Credo che basti una route map , dai anche un'occhiata al track delle route .


Secondo me basta solo il track delle route con quella di backup precedenza minore.


Top
 Profilo  
 
 Oggetto del messaggio:
MessaggioInviato: mar 28 dic , 2010 10:21 am 
Non connesso
Cisco pathologically enlightened user
Avatar utente

Iscritto il: lun 18 ott , 2010 11:05 am
Messaggi: 216
non conosco il comando "route-map" adesso do un'occhiata e vediamo che fa e come funziona... grazie mille

vedrò anche il track delle route.. vi ringrazio


Top
 Profilo  
 
 Oggetto del messaggio:
MessaggioInviato: mer 29 dic , 2010 10:58 am 
Non connesso
Cisco pathologically enlightened user
Avatar utente

Iscritto il: lun 18 ott , 2010 11:05 am
Messaggi: 216
ho risolto con route-amp!

ecco le parti rilevanti della configurazione:

Codice:
ip nat inside source route-map PRI-WAN interface Dialer0 overload
ip nat inside source route-map SEC-WAN interface Dialer1 overload
!
ip access-list extended WAN-1
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended WAN-2
permit ip 192.168.1.0 0.0.0.255 any
!
route-map SEC-WAN permit 1
match ip address WAN-2
match interface Dialer1
!
route-map PRI-WAN permit 1
match ip address WAN-1
match interface Dialer0


spero possa essere utile :D


Top
 Profilo  
 
 Oggetto del messaggio:
MessaggioInviato: mer 29 dic , 2010 11:24 am 
Non connesso
Messianic Network master

Iscritto il: ven 29 gen , 2010 10:25 am
Messaggi: 2054
Località: Prov di GE
Ciao,
questa è più una configurazione di load balance invece che backup.
Comunque, secondo me, potrebbe darti dei problemi di navigazione una soluzione del genere. Magari mi sbaglio.

Buona giornata


Top
 Profilo  
 
 Oggetto del messaggio: Re: configurare cisco 1841 con 2 wic adsl + NAT
MessaggioInviato: mer 29 dic , 2010 10:52 pm 
Non connesso
n00b

Iscritto il: ven 30 ott , 2009 10:39 pm
Messaggi: 3
Oltre a quanto indicato da gli altri, ti suggerisco

http://www.nil.com/ipcorner/SmallSiteMultiHoming/

La soluzione descritta sembra fare al tuo caso.

Ciao


Top
 Profilo  
 
 Oggetto del messaggio:
MessaggioInviato: gio 30 dic , 2010 2:45 pm 
Non connesso
Cisco pathologically enlightened user
Avatar utente

Iscritto il: lun 18 ott , 2010 11:05 am
Messaggi: 216
l'ultimo link è fantastico!!!!!!

quello che esattamente cerco di fare è quanto segue:

ho 4 line adsl, 2 cisco 1841 con 2 hwic adsl ognuno.

abilitato il glbp per fare load balancing tra i due router (quindi su due linee adsl)

le altre due linee adsl le devo tenere come linee dedicate per alcune reti particolari, ma in caso di problemi sulle linee primarie, quelle dedicate devono dare la possibilità di mantenere la connettività completa.

ecco la configurazione completa:

Codice:
Current configuration : 3658 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname sis-router2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$HGKk$Ln464RdX1fKQZA0dpAbAt0
!
no aaa new-model
ip cef
!
!
!
!
ip domain name sislocal
multilink bundle-name authenticated
vpdn enable
!
vpdn-group pppoe
request-dialin
  protocol pppoe
l2tp tunnel receive-window 1024
!
!
!
archive
log config
  hidekeys
!
!
!
track 100 interface ATM0/0/0 line-protocol
delay down 10 up 20
!
!
!
interface FastEthernet0/0
description Interface connected to RED interface on ENDIAN
ip address 192.168.1.11 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
glbp 1 ip 192.168.1.1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface ATM0/0/0
description Phone line number XXXXXX
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 8/35
  pppoe-client dial-pool-number 1
!
!
interface ATM0/1/0
description Phone line number XXXXXX
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
pvc 8/35
  pppoe-client dial-pool-number 2
!
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname SISADSL2
ppp chap password 7 XXXXXXXXXXXXX
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 2
ppp authentication chap callin
ppp chap hostname SISADSLI
ppp chap password 7 XXXXXXXXXXXX
!
router rip
version 2
network 192.168.1.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0 10 track 100
ip route 0.0.0.0 0.0.0.0 Dialer1 251
ip route 174.120.XXX.XXX 255.255.255.240 Dialer1
ip route 174.121.XXX.XXX 255.255.255.248 Dialer1
ip route 174.122.XXX.XXX 255.255.255.248 Dialer1
ip route 174.122.XXX.XXX 255.255.255.192 Dialer1
!
!
ip http server
ip nat inside source route-map PRI-WAN interface Dialer0 overload
ip nat inside source route-map SEC-WAN interface Dialer1 overload
!
ip access-list extended WAN-1
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended WAN-2
permit ip 192.168.1.0 0.0.0.255 any
!
route-map SEC-WAN permit 1
match ip address WAN-2
match interface Dialer1
!
route-map PRI-WAN permit 1
match ip address WAN-1
match interface Dialer0
!
!
!
control-plane
!
banner motd ^C
                            _
      .::::::::::.        -(_)====u         .::::::::::.
    .::::''''''::::.                      .::::''''''::::.
  .:::'          `::::....          ....::::'          `:::.
.::'             `:::::::|        |:::::::'             `::.
.::|               |::::::|_ ___ __|::::::|               |::.
`--'               |::::::|_()__()_|::::::|               `--'
:::               |::-o::|        |::o-::|               :::
`::.             .|::::::|        |::::::|.             .::'
  `:::.          .::\-----'        `-----/::.          .:::'
    `::::......::::'                      `::::......::::'
      `::::::::::'                          `::::::::::'

    This is the Sanaa International School router
    You are supposed to be here only if Authorized,
    if you are not, please go away, all not authorized
    accesses are logged and will be pursued by law.

^C
!
line con 0
password 7 051A1506731C1E515844
logging synchronous
login
line aux 0
line vty 0 4
password 7 06171C281E1E59414456
logging synchronous
login
line vty 5 30
password 7 06171C281E1E59414456
logging synchronous
login
!
scheduler allocate 20000 1000
end


sull'altro router la configurazione è praticamente identica.

vi ringrazio tantissimo, siete stati utilissimi, spero che questa configurazione "completa" (per adesso) possa aiutare qualcuno in furuto


Top
 Profilo  
 
Visualizza ultimi messaggi:  Ordina per  
Apri un nuovo argomento Rispondi all’argomento  [ 9 messaggi ] 

Tutti gli orari sono UTC + 1 ora


Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite


Non puoi aprire nuovi argomenti
Non puoi rispondere negli argomenti
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi inviare allegati

Vai a:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Traduzione Italiana phpBB.it
Cisco, Cisco Systems e tutti i marchi implicitamente collegati sono trademarks registrati di Cisco Systems Inc.
Ciscoforums.it è una comunità senza fini di lucro e non è in alcun modo affiliata a Cisco Systems